FAQ KB0405759
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What are the most common errors encountered during legacy contract import?
Symptom

What are the most common errors encountered during legacy contract import?

How do I resolve common legacy contract import errors?


Resolution

The following list includes the most common errors encountered when importing legacy contracts. Select the error's text to jump to it's row in the table:

  1. FileNotFoundException: filename (No such file or directory)
  2. You do not have a published template named...
  3. Template name is not applicable
  4. next() encountered AQL Parsing Error: Mal-formed string literal processing statement...
  5. NoSuchElementException: null
  6. User '' not found error (or) User 'null' not found (or) Of ContractId instances with ='[BaseId]', one has DocumentId [BaseId], but another has (missing argument)
  7. Field fieldName not found...
  8. Skipping MONEY FIELD due to exception ParseException: Cannot find currency with prefix=$ and suffix=null
  9. Error saving the file content for the document ContractDocuments.csv: java.io.FileNotFoundException
  10. Exception when Zipping up directory...
  11. Error parsing "username@domain.com": Number of lookup keys does not match with the number of values given.

The following table

SL NoError Cause and Solution
1FileNotFoundException: filename (No such file or directory)

Cause:

  • The legacy import ZIP archive was created from a folder instead of the individual documents.
    • You must create the archive file directly from the CSV files and any additional documents that you plan to upload. If you add the CSVs and other documents to a folder, then create the ZIP archive from the folder, the import process will fail.
  • File names mentioned in ImportProjectParameters.csv are incorrect - names must be as per standard CSV filename or format and they are case sensitive.
  • One or more of the 4 CSV files is missing.
    • Each legacy import ZIP file must contain all the required CSV files.
    • You must still include ContractDocuments.csv and ContractTeams.csv even if the files are empty.
  • The ImportProjectParameters.csv file is missing.

Solution:

  1. Correct the errors in the ZIP archive or its files.
  2. Retry the import.

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2You do not have a published template named ...

Cause:

  • This error occurs when the template mentioned in ImportProjectParameters.csv is Inactive or not published (Draft status).

Solution:

  1. Reactivate and publish the template.
  2. Retry the import.

Additional information

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3Template name is not applicable

Cause:

  • The template mentioned has a visibility condition set on it hence it cannot be used.

Solution:

  1. Create a new version of the template.
  2. Remove the visibility condition
  3. Publish the new template version.
  4. Retry the import.

Additional information:

  • We recommend to have a separate empty template created which can be used just to import legacy contracts.

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4next() encountered AQL Parsing Error: Mal-formed string literal processing statement...

Cause:

  • The CSV import file contains a line break in one of indicated columns values.

Solution

    1. Open the CSV file in a simple text editor.
    2. Locate the values for the column mentioned in the error and remove the line break or space
    3. Save your changes.
    4. Create a new legacy import ZIP archive.
    5. Retry the import.

Additional information:

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5NoSuchElementException: null

Cause:

  1. Text in one of the fields in the CSV import file contains double quotation marks ("), most likely near the end of the entry.

Solution:

  1. Open the CSV file in a simple text editor.
  2. Locate the entries for the last successfully imported row.
  3. In the next row (the row that corresponds to the error), check the entries for double quotation marks (").
  4. Remove the double quotation marks.
  5. Save your changes.
  6. Create a new legacy import ZIP archive.
  7. Retry the import.

Additional Information

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6User '' not found error or

User 'null' not found or

Of ContractId instances with ='[BaseId]', one has DocumentId [BaseId], but another has (missing argument)

Cause:

  • You reused one of the CSV files from a previous legacy import, but entered fewer rows of data.

Solution:

  1. Open the CSV file in a simple text editor.
  2. Go to the end of the file and check for rows that contain only commas (,).
  3. If present, delete these rows.
  4. Save your changes.
  5. Create a new legacy import ZIP archive.
  6. Retry the import.

Additional information:

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7Field FieldName not found...

Cause:

  • The unique name of one of the the fields used as a column header is incorrect. It begins with cus_FieldName.
  • If the error is stating that 'Customer' does not exist, this header value needs to be Supplier.

Solution:

  1. Open each CSV file and review the column header values.
    • Any custom fields must use the field name value (typically formatted as cus_FieldName), not the label value that displays in the user interface.
    • If the error states Field Customer not found... , then replace the column header 'Customer' with 'Supplier'
  2. Save your changes.
  3. Create a new legacy import ZIP archive.
  4. Retry the import.

Additional information:

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8

Skipping MONEY FIELD due to exception ParseException: Cannot find currency with prefix=$ and suffix=null

Cause:

  • You included currency symbols (such as $, €, or ¥) in the entries for money fields.

Solution:

  1. Open the CSV file and remove any currency symbols.
  2. Save your changes.
  3. Create a new legacy import ZIP archive.
  4. Retry the import.

Additional information:

  • To enter a specific currency in a money field, you must enter the value with the format 'MONEY VALUE CURRENCY ABBREVIATION. The following lists entries demonstrate this format:
    • '50 USD
    • '1000 EUR
    • '80000 JPY
  • Import Legacy Contracts: Currency Error

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9

Error saving the file content for the document ContractDocuments.csv: java.io.FileNotFoundException

Cause:

  • The name of the document mentioned in the error doesn't match the name of any of the entries in the File column of ContractDocuments.csv file.

Solution:

  1. Open the ContractDocuments.csv file.
  2. Ensure all entries in the File column match the names of the documents you're trying to import.
  3. Save your changes.
  4. Create a new legacy import ZIP archive.
  5. Retry the import.

Additional information:

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10Exception when Zipping up directory...

Cause:

  • You've included special characters in any of the following places:
    • The name of a document you're importing.
    • An entry in the File column of the ContractDocuments.csv file.

Solution:

  1. Remove special characters from any of the files you'd like to import.
  2. Open the ContractDocuments.csv file.
  3. Update any entries in the File column affected by changing the file names.
  4. Save your changes.
  5. Create a new legacy import ZIP archive.
  6. Retry the import.

Additional information:

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11Error parsing "username@domain.com": Number of lookup keys does not match with the number of values given.

Cause:

  • One of the lookup values required to locate the field's value in the site is missing.
  • For example, you must add entries in the User field with the following format: [passwordadapter]:[username]. If the [passwordadapter] value is missing, you'll encounter this error.

Solution:

  1. Open the CSV file and locate the entry mentioned in the error.
  2. Correct the entry's format so it includes the necessary values.
  3. Save your changes.
  4. Create a new legacy import ZIP archive.
  5. Retry the import.

Additional Information

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Applies To

Strategic Contracts > Strategic Contracts Import/Export

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