Support Note KB0392804
Email
Error: Legacy Load Error: Number of lookup keys does not match with the number of values given
Issue

When I import a legacy contract, I get the error

Legacy Load Error: Number of lookup keys does not match with the number of values given.

The details for the error are similar to the following:

Error parsing "username@domain.com": Number of lookup keys does not match with the number of values given.
Classname = ariba.user.core.User
Lookup Keys passed as argument = 1
Lookup Keys found in metadata = 2
Lookup Keys = ( PasswordAdapter, UniqueName )

Resolution

If the error refers to a user column, include the password adapter as part of the value for that column.
User columns in the import file should have the following format:

[password adapter]:[username]

For example, to refer to an enterprise user with the username example@company.com, use the value below:

PasswordAdapter1:example@company.com

Similarly, if this error refers to a commodity code column, include the domain of the commmodity code when importing:

[domain]:[commodity code]

For example, to refer to a UNSPSC commodity code 109103, use the value below:

unspsc:109103

Cause

The system uses multiple keys to look up data for a column in the import file, but the import file value does not have enough keys to uniquely identify the object.


Applies To

Strategic Contracts
Strategic Sourcing

Terms of Use  |  Copyright  |  Security Disclosure  |  Privacy