Support Note KB0400481
Email
Error: "Supplier Name not available"
Issue

My Purchase Order (PO) routed through Cloud Integration Gateway (CIG) are not carrying routing details and failing with below error message:

"Bad Request" and Error Code:"400" and Error Code Response: Error: Supplier Name not available. Please contact support with the Error Reference Number: ANERR-40000000000000001277504940 for more details. Suggested Action : Document Failed in Ariba Network. For further assistance, please contact Ariba Support with the code mentioned in Response. CIG Support Error Code : CIG-PLT-00644.

Resolution

Routing details in the Purchase Order IDOC are made available under Ariba's extended segments. Customer had not implemented exits in the ERP due to which source document was not carrying Ariba's extended segments. Since the source document was missing the data, the same was not getting passed to the target as well and the PO was failing.

Cause

Steps from the How to implement a customer exit for purchase orders can be followed to implement customer exit for purchase orders.


Applies To

SAP Integration Suite Managed Gateway > Managed Gateway for Business Network

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