FAQ KB0684337
Email
Error: "Account already registered with the given buyer. Use another account to complete registration or create a new account".
Symptom

While trying to register, my supplier gets Error: Account already registered with the given buyer. Use another account to complete registration or create a new account


Cause

There could be two or more supplier organizations created in your (buyer) realm. One is already linked with a supplier Business Network account (ANID linked to their supplier organization). The other is without any ANID (Business Network account) linked.

When you send an invite for a questionnaire to the account without ANID, then your supplier will need to connect the account with ANID by logging into their ANID or creating one.

When the supplier with the invite without ANID tries to connect their ANID because it is linked to another supplier organization in your realm, it will face the issue as it is unallowed to link two or more organizations with the same SAP Business Network account.

There will be two or more users with the same email address in your (buyer) realm, of which one is registered with this SAP Business Network account with your (buyer) organization.

Another user is also trying to register with the same SAP Business Network username, which is registered with the buyer. Hence getting this error.


Resolution

To resolve this issue, you need to identify if there is a duplicated organization creation. Please follow the steps below:

  1. Identify the supplier email address invited.
  2. Go to Manage > Administration > Supplier and Customer Manager > Users.
  3. Search by the email from step 1.
  4. For each UserID found, check the supplier's organization details by clicking their company name (in blue letters) in the Organization column.
  5. Invite the user who is already registered and change the email address of the second user to a different email ID.
  6. Unlink the SAP Business Network user ID for an existing supplier and change the email address. Then, the second user can register with the same ANID.

See Also

What are some common issues when registering an account?

How can I edit the notification email that goes to suppliers when we invite them to register?



Applies To

Guided Sourcing > Guided Sourcing Event > Guided Sourcing Supplier Issues In Event
Strategic Sourcing > Strategic Sourcing - Supplier Status In Event
Supplier Information & Performance Management > SIPM Registration/Login
Supplier Lifecycle & Performance > Supplier Lifecycle & Performance Registration

Terms of Use  |  Copyright  |  Security Disclosure  |  Privacy