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失败:关闭/重新打开订购单 xyz 的请求永久失败
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问题

当用户手动或自动关闭订单时,抬头上的关闭字段将显示“等待外部系统的确认”,然后恢复,并且历史记录在操作列下显示“失败”。

单击 失败时,我们收到消息:“将订购单 xxx 的关闭/重新打开订单状态发送到外部系统的最大尝试次数失败。订单的状态已恢复到之前状态。”

检查历史记录时,这通常需要花费 10 到 14 小时,从用户启动“关闭”(单击关闭按钮)到失败的时间为止。

原因

当 Ariba 导出关闭状态时,将等待来自 ERP(发生导出的外部系统)的成功确认。

如果导出事件成功发生,但未返回成功响应,则 Ariba 将重试发送订单关闭请求,总共 6 次。

尝试间隔约为 2 小时(可能因初始导出发生的时间而异,因此可能需要 10 到 14 小时才能失败)。

如果所有尝试都已耗尽,并且仍未收到成功响应,则关闭操作将失败,关闭状态将恢复为先前状态。

可能导致此情况的响应示例:

解决方案

根据导致 ERP 不发送成功响应的原因,只需重试“关闭”或“重新打开”操作可能会起作用,如果不起作用,则需要从 ERP 端进一步调查,请参阅下一部分故障排除以获取有关如何继续的更多详细信息。

故障排除

如果您尝试再次关闭/重新打开订单,并在关闭状态上进入“等待来自外部系统的确认”,则永久失败,然后检索以下信息以开始调查,请注意,您需要让中间件和 ERP 团队参与此过程:

所有这些响应都应来自 ERP,为了纠正这些问题,您需要与 ERP 团队合作。

如何检索订单关闭的时间戳:

  1. 搜索受影响的订单,然后将其打开。
  2. 单击历史记录选项卡。
  3. 查找“关闭订单状态已发送到外部系统”条目和“失败”条目。
  4. 比较时间,确保此处分析的案例,差异应该在 10-14 小时左右,绝对不在分钟内。
  5. 记录“失败”时戳 DD:MM:YYYY HH:MM AM/PM。

正确的成功响应应包含以下内容:

附加信息

领域配置可以设置为:

如果 Close 尝试和失败之间的时间差仅为几分钟,则您可能会遇到不同的问题,有关详细信息,请参阅 192493

另一个可能的问题是:192157


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