Nota de asistencia técnica KB0395501
Correo electrónico
Error: PO-11: No se puede entregar el pedido. Código de error de terminal para estado de pedido: No se ha podido analizar sintácticamente el documento
Este artículo de la base de conocimientos ha sido traducido automáticamente para su comodidad. SAP no ofrece ninguna garantía con respecto a la exactitud o integridad de la traducción automática. Puede acceder al contenido original si cambia al inglés mediante el selector de idiomas.
Síntoma

Los pedidos de compra (PO) no llegan al sistema integrado del proveedor. La pestaña Historial de pedido muestra el siguiente mensaje de error.

Error: PO-11: No se puede entregar el pedido. Código de error de terminal para estado de pedido: ¿No se ha podido analizar sintácticamente el documento?


Causa

Puede haber dos causas probables:


Resolución

Primera causa de la solución: el proveedor debe revisar por qué se envía una respuesta cXML no válida a SAP Business Network.

Un ejemplo de una respuesta correcta:

<?versión xml="1.0" codificación="UTF-8"?>
<!DOCTYPE cXML SYSTEM "http://xml.cxml.org/schemas/cXML/1.2.014/cXML.dtd">
<cXML payloadID="994994" xml:lang="en" timestamp="2002-03-12T18:39:09-08:00">
<Respuesta>
<Código de estado="200" texto="OK"/>
</Respuesta>
</cXML>

Solución de la segunda causa: Corrija el cXML de pedido eliminando los espacios adicionales en la etiqueta cXML afectada.


Véase también

Para obtener información adicional sobre la integración cXML, consulte la Guía de soluciones cXML.

Consulte esta lista de errores de integración comunes para obtener una lista de errores similares comunes y su resolución.



Se aplica a

SAP Business Network for Procurement & Supply Chain > Documentos de transacción
SAP Business Network for Procurement & Supply Chain > Documentos de transacción > Transacción (Pedidos de compra, avisos de expedición y entrada de mercancías)

Condiciones de uso  |  Copyright  |  Declaración de seguridad  |  Privacidad