Destek Notu 192400
E-posta
Error: "PO-11: Cannot deliver order. (...) Failed after unsuccessful attempts to resend it." when sending email PO to supplier
Issue

Purchase order is failing in Ariba Network, not reaching the supplier email. When we see the History tab for the PO in Ariba Network (buyer), we see the error below:

PO-11: Cannot deliver order. Terminal error code for PO status: The state of document XXXXXXXXXXXXXXXXXXXXXXXXXX was changed to Failed after unsuccessful attempts to resend it.

The supplier is able to view the PO in their Inbox, but it is marked as Failed. In the PO History tab in Ariba Network (supplier), they can see the error below for the order:

PO-3: Cannot send order to supplier.

The Stacktrace column in the PO History tab in Ariba Network (supplier) shows the exception below:

com.webobjects.foundation.NSValidation$ValidationException: The emailAddress property of ANEmailTracker is not allowed to be null. (...)

Additionally, in both buyer and supplier side of Ariba Network it is possible to see the line below in the History tab of the purchase order, shown several times:

Transfer to the next integration point has been delayed. Retries: X

Resolution

The supplier needs to:

  1. either enter a valid email address in their Settings > Electronic Order Routing
  2. or change the Routing Method in their Settings > Electronic Order Routing to a different method (such as Online)

After the cause of the issue is resolved, the supplier can resend the PO to themselves. See What can I do with a failed purchase order? for step by step instructions.

Cause

The supplier didn't configure an email address in their Electronic Order Routing section, but have set the Routing Method to Email. This caused the PO to be marked as Failed.

Additional Information

See Purchase orders are failing to reach the supplier email, but can be seen in the supplier's Inbox for a list of common similar errors and their resolution.

If the supplier receives their orders in an integrated system instead of email, refer to Error: "PO-11: Cannot deliver order. (...) Failed after unsuccessful attempts to resend it." when sending PO to integrated supplier.


Kapsam

SAP Business Network

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