Support Note KB0404660
Email
Error: "PO-11: Cannot deliver order. Terminal error code for PO status" when sending Purchase Order (PO) via email
Symptom

PO is failing and not reaching the supplier email. The History tab for the PO shows the error:

PO-11: Cannot deliver order. Terminal error code for PO status: The state of document XXXXXXXXXXXXXXXXXXXXXXXXXX was changed to Failed after unsuccessful attempts to resend it.

The supplier is able to view the PO in their Inbox, but it is marked as Failed. In the PO History tab, the error PO-3: Cannot send order to supplier is displayed for the order.

The Stacktrace column in the PO History tab shows the exception:

com.webobjects.foundation.NSValidation$ValidationException: The emailAddress property of ANEmailTracker is not allowed to be null. (...)

Additionally, in both buyer and supplier accounts, it is possible to see Transfer to the next integration point has been delayed. Retries: X in the History tab of the PO, shown several times.


Cause

The supplier didn't configure an email address in their Electronic Order Routing section but have set the Routing Method to Email. This caused the PO to be marked as Failed.


Resolution

The supplier has 2 options to correct this.

Once corrective action has been taken, the supplier can resend the PO to themselves.


See Also

See Purchase orders are failing to reach the supplier email, but can be seen in the supplier's Inbox for a list of common errors and their resolution.

If the supplier receives their orders in an integrated system instead of email, refer to Error: "PO-11: Cannot deliver order. (...) Failed after unsuccessful attempts to resend it." when sending PO to integrated supplier.



Applies To

SAP Business Network for Procurement & Supply Chain > Transaction Documents > Transaction (Purchase Orders, Ship Notices & Goods Receipts)

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