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Posta elettronica
Non riuscito: la richiesta di chiusura/riapertura dell'ordine d'acquisto xyz non è riuscita in modo permanente
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Problema

Quando un ordine viene chiuso, manualmente da un utente o automaticamente, il campo di chiusura nell'intestazione mostrerà "in attesa di conferma dal sistema esterno", quindi torna indietro e la cronologia mostra "Non riuscito" sotto la colonna Azione.

Quando si fa clic su Non riuscito, viene visualizzato il messaggio: "Numero massimo di tentativi di invio dello stato di chiusura/riapertura dell'ordine d'acquisto xxx al sistema esterno non riuscito. Lo stato dell'ordine è stato ripristinato allo stato precedente."

Ciò richiede solitamente 10-14 ore durante il controllo dello storico, tra l'ora in cui l'utente avvia Chiudi (facendo clic sul pulsante Chiudi) e l'ora in cui non riesce.

Causa

Quando esporta lo stato di chiusura, Ariba attenderà una conferma di corretta esecuzione dal sistema ERP (il sistema esterno in cui avviene l'esportazione).

Nel caso in cui l'evento di esportazione avvenga correttamente, ma non si ripresenti alcuna risposta di corretta esecuzione, Ariba tenterà nuovamente di inviare la richiesta di chiusura dell'ordine per un totale di 6 volte.

L'intervallo tra i tentativi è di circa 2 ore (può variare in base a quando è avvenuta l'esportazione iniziale, quindi possono essere necessarie da 10 a 14 ore prima di fallire).

Se tutti i tentativi sono esauriti e non viene ancora fornita alcuna risposta di corretta esecuzione, l'azione di chiusura non riuscirà e lo stato di chiusura tornerà a quello precedente.

Esempi di risposte che potrebbero causare ciò:

Risoluzione

A seconda di ciò che ha causato il mancato invio della risposta di corretta esecuzione da parte di ERP, potrebbe semplicemente funzionare il tentativo di chiudere o riaprire; in caso contrario, saranno necessarie ulteriori indagini da parte di ERP; fare riferimento alla sezione successiva, Risoluzione dei problemi, per ulteriori dettagli su come procedere.

Eliminazione degli errori

Se si tenta di chiudere/riaprire nuovamente l'ordine e questo passa a "In attesa di conferma da sistema esterno" nello stato di chiusura, l'operazione fallisce definitivamente, quindi si recuperano le seguenti informazioni per avviare l'indagine, tenere presente che sarà necessario coinvolgere il middleware e il team ERP per questo:

Tutte queste risposte dovrebbero provenire dall'ERP, quindi per correggerle sarà necessario coinvolgere il team ERP.

Modalità di recupero della data e dell'ora di chiusura dell'ordine:

  1. Cercare l'ordine interessato e aprirlo.
  2. Fare clic sulla scheda Cronologia.
  3. Cercare la voce "Lo stato di chiusura dell'ordine è stata inviata al sistema esterno" e la voce "Non riuscito".
  4. Confrontare i tempi, per assicurarsi che sia il caso analizzato qui, la differenza dovrebbe aggirarsi intorno alle 10-14 ore e sicuramente non in minuti.
  5. Annotare il timestamp di "Non riuscito", GG:MM:AAAA HH:MM AM/PM.

Una risposta corretta di corretta esecuzione deve contenere quanto segue:

Informazioni supplementari

La configurazione del realm può essere impostata su:

Se la differenza di tempo tra il tentativo di chiusura e l'errore è di pochi minuti, si potrebbe riscontrare un problema diverso; per ulteriori informazioni, fare riferimento a 192493

Un'altra possibile questione sarebbe: 192157


Si applica a

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