Nota de asistencia técnica KB0404544
Correo electrónico
El estado Cerrar pedido no se exporta al sistema ERP.
Este artículo de la base de conocimientos ha sido traducido automáticamente para su comodidad. SAP no ofrece ninguna garantía con respecto a la exactitud o integridad de la traducción automática. Puede acceder al contenido original si cambia al inglés mediante el selector de idiomas.
Síntoma

Al intentar cerrar un pedido, en el histórico veo el error Fallido: el estado Cerrar pedido no se ha enviado al sistema externo y el estado de cierre no se exporta al sistema Enterprise Resource Planning (ERP).


Causa

Esto se debe a que no hay ninguna tarea habilitada para exportar el estado Cerrar pedido.

En este caso, Ariba lo establecerá por defecto en Canal de archivos, pero aún no podrá exportarlo y el pedido permanecerá en espera de confirmación del sistema externo para el estado de cierre en función de la configuración que tenga.

Otra posible causa sería que tenga SAP Integration Suite Managed Gateway para la gestión de gastos y SAP Business Network configurados para exportar el estado de cierre, pero no tenga la tarea activada en Gestor de integración -> SAP Integration Suite Managed Gateway para la gestión de gastos y SAP Business Network.


Resolución

Dado que puede ver que no hay ninguna tarea habilitada, significa que se establece por defecto en la tarea Canal de archivo Exportar estado de cierre de pedido de compra.

Para deshacerse del indicador, puede utilizar la tarea de importación manual Importar estado cerrado de pedido de compra para importar una confirmación correcta o un error manualmente.

La elección de qué archivos importar dependerá de su proceso empresarial y de los requisitos del pedido, por ejemplo, si el pedido está abierto en ERP y cerrado en SAP Ariba, es posible que desee importar la respuesta de error para revertir el estado a abierto para que tanto SAP Ariba como ERP estén sincronizados.

Para obtener orientación sobre cómo crear manualmente archivos CSV para importaciones de canal de archivos, consulte el artículo ¿Cómo puedo crear un archivo CSV para la importación manual?


Ver también

Para evitar este problema, asegúrese de que haya al menos una de las tareas Importar estado de cierre de pedido de compra habilitadas para Canal de archivos, Gateway gestionado para gastos y red o WS (servicios web).

Si Managed Gateway for Spend & Network está configurado, asegúrese de que la tarea en sí esté activada en la lista de tareas en Gestor de integración -> SAP Integration Suite, gateway gestionado para la gestión de gastos y SAP Business Network.



Se aplica a

Compras
Compras > Pedidos de compra

Condiciones de uso  |  Copyright  |  Declaración de seguridad  |  Privacidad