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Como resolvo recibos que não estão sendo enviados para meu ERP?
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Sintoma

Os recibos (bem como os recibos negativos/reversos) são criados no SAP Business Network, mas estão falhando devido a um erro de push de ERP.


Causa

Ao receber um erro de push de ERP, investigue em sua solução de compras externas para descobrir se as informações estão ausentes ou incompletas.

Se o erro for porque o pedido não pode ser encontrado em seu ERP, certifique-se de que o pedido não foi Forçar pedido nem excluído no ERP depois de ter sido enviado da SAP. As operações futuras não são suportadas para pedidos forçados, consulte o documento Transmissão do pedido e pedidos com falha.


Resolução

Entendendo o fluxo de trabalho do recibo:

Em situações em que o erro não pode ser corrigido, recomendamos as seguintes abordagens:

Opção 1 (recomendado):
Forçar o processamento do recibo usando o botão Forçar processo no cabeçalho do recibo. Em seguida, crie o recibo manualmente no ERP.

Opção 2:
Se a criação manual de recibos não for permitida ou não for possível:

  1. Forçar o processo dos recibos parados (aquele(s) que recebe erros de push de ERP).
  2. Certifique-se de que qualquer novo recibo receberá também um Erro de push de ERP. Sugestão: marcar Entrega concluída ou fechar o pedido para recebimento no ERP, não no SAP Ariba Procurement, pode ajudar.
  3. Crie um novo recibo que reverterá o recibo parado: se o primeiro recibo tiver a quantidade 1, o recibo de estorno deverá ter a quantidade -1 e vice-versa.
  4. Envie o novo recibo.
  5. Depois disso, o novo recibo de estorno também deve ser Processado forçadamente.
  6. Isso deixará o pedido na SAP Ariba com 2 recibos cancelando um ao outro.
  7. Anule as modificações efetuadas na etapa 2.
  8. Agora você precisa garantir que qualquer novo recibo criado fluirá com êxito para o ERP e, em seguida, criará um novo recibo.

Cuidado: teste primeiro para garantir que nenhum passo seja perdido ou se há recebimento complexo realizado no pedido. É importante entender a lógica e pode variar com base na resposta do ERP. Por exemplo, se o ERP aceitar o recibo negativo e o lançar em vez de enviar o erro de volta, essa abordagem não poderá ser seguida.


Opção 3:
Edite o recibo com erro de push de ERP, defina o Valor aceito/Número aceito como 0 e reenvie. Use o botão Fechar pedido no recibo (o pedido ainda pode ser reaberto).

Atenção: não utilize esta opção se existirem novos recibos lançados em relação ao pedido. Mesmo que estejam no estado Processado e exportados para ERP, eles serão removidos. Essa opção também não é possível se seu site estiver ativado para o fechamento no nível da linha do pedido de compra.


Veja também

Para ler mais sobre documentações específicas sobre o recebimento, consulte abaixo:



Aplicável a

Compras > Recebimento
Compras > Recebimento > Importação/exportação de recibo

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