Support Note KB0402136
Email
Why can I not change a parameter in a production site via the Intelligent Configuration Manager (ICM)?
Symptom

I'm assigned to the Customer Administrator group, but I’m unable to update a self-service parameter using Intelligent Configuration Manager in a production realm.


Reproducing the Issue

On a production site go to Manage > Administration (for Sourcing) or Core Administration (for Buyer).

  1. Click Intelligent Configuration Manager > Manage Configuration

  2. Click Continue.

  3. Click Buying and Invoicing (for Buyer) or Sourcing and Contracts (for Sourcing).

  4. Select Parameters from the drop-down list.

  5. Search for the parameter you want to change.

  6. See that there is no option to update the parameter value.


Cause

By system design, when working on a production site, members of the Customer Administrator group have read-only access to Intelligent Configuration Manager (ICM), preventing them from making changes directly in the production realm.


Resolution

To change the parameter value in a production realm:

  1. Create and deploy a package as per how can I change a parameter in an SAP Ariba Procurement Solutions site?
  2. Check that the parameter has been updated in the production realm.

See Also

KB0408463 - How can I change a parameter in an SAP Ariba Procurement Solutions site?

SAP Help Portal > SAP Ariba Procurement Solutions > Intelligent Configuration Manager Administration > Parameter Management in Intelligent Configuration Manager
SAP Help Portal > SAP Ariba Procurement Solutions > Intelligent Configuration Manager Administration > Workflow for Updating Configurations for the Site
SAP Help Portal > SAP Ariba Procurement Solutions > Intelligent Configuration Manager Parameters Reference



Applies To

Procurement Application Services > Intelligent Configuration Manager (ICM)

Terms of Use  |  Copyright  |  Security Disclosure  |  Privacy