Nota di supporto KB0402013
Posta elettronica
Perché l'allegato inviato nella fattura o nella conferma d'ordine da SAP Business Network al sistema SAP ERP tramite il gateway gestito per gestione della spesa e SAP Business Network non è visibile?
Per comodità dell'utente, questo articolo della Knowledge Base è stato tradotto automaticamente. SAP non fornisce alcuna garanzia in merito alla correttezza o alla completezza della traduzione automatica. È possibile visualizzare il contenuto originale passando all'inglese nel selettore della lingua.
Sintomo

Quando invio una fattura (InvoiceDetailRequest) o una conferma d'ordine (OrderConfirmation) con un allegato da SAP Business Network a SAP Enterprise Resource Planning (ERP) tramite l'integrazione del gateway gestito per gestione della spesa e SAP Business Network, non riesco a trovare l'allegato nell'elenco degli allegati nel sistema ERP.


Causa

La configurazione necessaria non è presente in SAP ERP.


Soluzione

Questo problema si verifica generalmente a causa di una specifica configurazione mancante nella configurazione dei profili partner per l'integrazione del gateway gestito per gestione della spesa e SAP Business Network. Per confermare questo punto, è necessario attenersi alle seguenti fasi:

  1. Aprire la transazione WE20.
  2. Fare clic su Configurazione ARIBACIG/ARBCIG in Tipo di partner LS.
  3. Fare doppio clic su INVOIC per la fattura, o ORDRSP per la conferma d'ordine, nei Parametri di entrata.
  4. Fare doppio clic su INVL per la fattura, o ORDR per la conferma dell'ordine, nel Codice processo nella scheda Opzioni in entrata.
  5. Sul lato destro di Identification > IDOC_INPUT_INVOIC_MRM per la fattura o IDOC_INPUT_ORDRSP per la conferma d'ordine, fare clic sul pulsante Tabella ALE.

Dopo aver eseguito questi passi si accede alla view di visualizzazione "Function module per ALE-EDI in entrata": videata dettagli. Nella sezione IDoc sarà presente un'etichetta specifica chiamata Evento riuscito. Questa etichetta non può essere vuota, il suo valore deve essere uguale a INPUTSUCCESS.

È molto importante sapere che affinché gli allegati funzionino come previsto, devono essere presenti tutte le configurazioni menzionate nella guida alla configurazione di SAP Integration Suite, gateway gestito per gestione della spesa e SAP Business Network Modalità di abilitazione di allegati e commenti per le fatture e Modalità di abilitazione degli allegati per la conferma d'ordine. Non funzionerà se, ad esempio, l' Evento configurato è MASSIMPUTFINISHED o se il Tipo oggetto è IDPKINVOIC. La configurazione deve essere eseguita come indicato nella guida.

Se la configurazione menzionata è già stata eseguita e il problema persiste, attenersi alla seguente procedura:

  1. Aprire la transazione SPRO.
  2. Fare clic su Integrazione con altri componenti SAP > SAP Integration Suite, gateway gestito per gestione della spesa e SAP Business Network > Impostazioni globali > Supporto allegati
  3. Fare clic su Aggiorna parametro per allegato a livello di voce da SAP Integration Suite, gateway gestito per gestione della spesa e SAP Business Network

Aggiungere i parametri come indicato nella Guida alla configurazione di SAP Integration Suite, gateway gestito per gestione della spesa e SAP Business Network Modalità di abilitazione degli allegati per la conferma d'ordine. Si noti che anche se questa sezione della guida fa riferimento solo alla conferma d'ordine, questa parte specifica della configurazione è necessaria per entrambi gli scenari.

Se dopo tutta la configurazione è stata eseguita e il problema persiste, fare riferimento alla procedura menzionata in Come raccogliere il trace per analizzare i problemi con gli allegati della fattura inviati da AN a ERP tramite il gateway gestito per gestione della spesa e SAP Business Network in IDOC? e aprire un caso segnalandolo con i registri trace allegati.


Vedi anche

Questo scenario ha una limitazione di progettazione per gli allegati a livello di voce. Eventuali allegati inviati a livello di riga non riusciranno sul lato ERP. Una soluzione alternativa potrebbe essere l'implementazione di una personalizzazione nelle customer exit ERP o nei punti di ampliamento.



Si applica a

SAP Integration Suite, gateway gestito > Gateway gestito per Business Network
SAP Integration Suite, gateway gestito > Gateway gestito per Business Network > Gateway gestito per Business Network - Conferma ordine
SAP Integration Suite, gateway gestito > Gateway gestito per Business Network > Gateway gestito per Business Network - Fattura

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