Nota de asistencia técnica KB0402013
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¿Por qué el adjunto enviado en la factura o la confirmación de pedido de SAP Business Network al sistema SAP ERP a través de Managed Gateway for Spend&Network no es visible?
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Síntoma

Cuando envío una factura (InvoiceDetailRequest) o una confirmación de pedido (OrderConfirmation) con un adjunto de SAP Business Network a SAP Enterprise Resource Planning (ERP) mediante la integración de Managed Gateway for Spend&Network, no encuentro el adjunto en la lista de adjuntos en ERP.


Causa

La configuración necesaria no está implementada en SAP ERP.


Resolución

Este problema suele deberse a que falta una configuración específica en la configuración de perfiles de socio para la integración de Managed Gateway for Spend&Network. Para confirmar este punto, se deben seguir los siguientes pasos:

  1. Abra la transacción WE20.
  2. Haga clic en la configuración ARIBACIG/ARBCIG en la clase de interlocutor LS.
  3. Haga doble clic en INVOIC para factura, u ORDRSP para confirmación de pedido, en Parámetros de entrada.
  4. Haga doble clic en INVL para factura, u ORDR para confirmación de pedido, en el Código de proceso en la pestaña Opciones de entrada.
  5. En la parte derecha de Identificación > IDOC_INPUT_INVOIC_MRM para factura, o IDOC_INPUT_ORDRSP para confirmación de pedido, haga clic en el botón Tabla ALE.

Después de realizar estos pasos, accederá a la pantalla Visualizar vista "Módulos de funciones para ALE-EDI de entrada": Detalles. Habrá una etiqueta específica en la sección IDoc llamada Evento de éxito. Esta etiqueta no puede estar en blanco, su valor debe ser igual a INPUTSUCCESS.

Es muy importante saber que para que los adjuntos funcionen como se esperaba, todas las configuraciones mencionadas en SAP Integration Suite, gateway gestionado para la gestión de gastos y la guía de configuración de SAP Business Network Cómo activar los adjuntos y los comentarios para las facturas y Cómo activar los adjuntos para la confirmación de pedido deben estar en su lugar. No funcionará si, por ejemplo, el evento configurado es MASSIMPUTFINISHED o si el ObjectType es IDPKINVOIC. La configuración debe realizarse como se menciona en la guía.

Si la configuración mencionada ya se ha realizado y el problema persiste, siga estos pasos:

  1. Abra la transacción SPRO.
  2. Haga clic en Integración con otros componentes de SAP > SAP Integration Suite Managed Gateway para la gestión de gastos y SAP Business Network > Configuración global > Adjuntos de soporte
  3. Haga clic en Actualizar parámetro para el adjunto a nivel de línea de SAP Integration Suite Managed Gateway para la gestión de gastos y SAP Business Network

Agregue los parámetros como se menciona en la Guía de configuración de SAP Integration Suite, gateway gestionado para la gestión de gastos y SAP Business Network Cómo activar los adjuntos para la confirmación de pedido. Tenga en cuenta que incluso si esta sección de la guía se refiere solo a la confirmación de pedido, esta parte específica de la configuración es necesaria para ambos escenarios.

Si después de todo la configuración está en su lugar y el problema aún existe, consulte los pasos mencionados en ¿Cómo recopilar el seguimiento para investigar problemas con los adjuntos de factura enviados de AN a ERP a través de Managed Gateway for Spend&Network en IDOC? y abra un caso notificándolo con logs de trace adjuntos.


Ver también

Este escenario tiene una limitación de diseño para los adjuntos a nivel de línea. Cualquier adjunto enviado en el nivel de línea fallará en el lado de ERP. Una solución alternativa sería implementar una personalización en los exits de cliente de ERP o en los puntos de ampliación.



Se aplica a

SAP Integration Suite, gateway gestionado > Gateway gestionado para Business Network
SAP Integration Suite, gateway gestionado > Gateway gestionado para Business Network > Gateway gestionado para Business Network - Factura
SAP Integration Suite, gateway gestionado > Gateway gestionado para Business Network > Gateway gestionado para Business Network - OC

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