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Requisição de compra travada no status Em solicitação
Sintoma

Minha requisição de compra (RC) está travada no status Em solicitação e o pedido de compra (PO) aparece em minha solução SAP Ariba Procurement, mas não em meu sistema de planejamento de recursos empresariais (ERP).


Causa

A solicitação de criação do pedido de compra foi enviada para o ERP, mas a solução de compras nunca recebeu uma resposta, por isso, a requisição de compra está travada no status Processamento de pedidos.


Resolução

Opção 1: reenvio dos pedidos de compra

Se você utilizar a integração para POs com base em serviço da Web (WS) ou SAP Integration Suite, gateway gerenciado para gerenciamento de despesas e SAP Business Network, você pode usar o recurso Reenvio aprimorado de pedidos de compra travados no estado Processamento de pedidos ou Em cancelamento para reenviar o pedido de compra.

Opção 2: importação de erro de push de ERP

Outra opção é usar Importação de erro de push de ERP para importar um erro de ERP para passar a RC de volta para o status Em composição que irá permitir excluir a RC. Esta opção também pode ser usada para o canal de arquivos.

  1. Em sua solução de compras, clique em Gerenciar > Administração principal > Importação/exportação de dados.
  2. Procure por Importar status de pedidos de compra ou Importação de erro de pedido de compra.
  3. Clique em Importar.
  4. Clique em Procurar e selecione o arquivo de valores separados por vírgulas (CSV) que contém o erro.
  5. Clique em Executar.
  6. Vá para a RC. Uma nova versão dela estará disponível no status Em composição.
  7. Clique no botão Desfazer alteração.
  8. O botão Excluir deve aparecer agora.

Não use esse método para pedidos de compra que já estão criados no seu ERP, mas estão travados no status Processamento de pedidos, porque eles não chegaram ao SAP Business Network.

Opção 3: forçar pedido

Outro método é usar a opção Forçar pedido para mover o pedido de compra para o status Pedidos enviados e, em seguida, cancelar o pedido e usar Forçar cancelamento para movê-lo para o status Cancelado. Isso não exclui o pedido de compra, mas encerra o fluxo de trabalho da requisição de compra/pedido de compra. Isso funciona como está para o canal de arquivos, mas para a integração WS ou ISMG (CIG), você deve habilitar o parâmetro Application.Purchasing.AllowForceCancelForForceOrderedERPOrders primeiro, caso contrário não será possível cancelar o pedido de compra. Esse método não é recomendado em geral, mas é possível.

  1. Em sua solução de compras, clique em Gerenciar > Pedidos de compra.
  2. Procure pelo pedido de compra pelo Código da requisição (consulte Como obtenho o número EP do pedido para uma requisição travada no processamento de pedidos? se precisar de ajuda a localizar um pedido de compra).
  3. Clique no hiperlink do título do pedido de compra.
  4. Clique em Forçar pedido, adicione comentários e clique em OK.
  5. Para cancelar a RC/PO, siga os passos 1-3 e, em seguida, clique em Cancelar.
  6. Uma nova versão da RC é criada nesse momento e, se não existir um fluxo de aprovações configurado, o pedido de compra/RC é passado para o status Em cancelamento. Clique em Forçar cancelamento no pedido.

Considere que usar Forçar pedido significa que todas as operações futuras no pedido não serão suportadas.


Veja também

Você pode verificar o tipo de integração seguindo estes passos:

  1. Em sua solução de compras, clique em Gerenciar > Administração principal > Gerenciador de integração.
  2. Clique em Configuração de integração.
  3. Procure por Exportar pedidos de compra.
  4. Na coluna Formato, verifique se é exibido Canal de arquivos, Serviço da Web ou Gateway gerenciado para despesas e Network.

Para Importação de erro de push de ERP, você precisará do seguinte:

Se seu pedido de compra tiver alcançado o status Falhapermanente, consulte como resolver aqui.



Aplicável a

Compras > Pedidos de compra
Compras > Requisições
SAP Integration Suite, gateway gerenciado > Gateway gerenciado para Procurement

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