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Demande d'achat bloquée au statut Commande en cours
Symptôme

Ma demande d'achat est bloquée au statut Commande en cours et le bon de commande (BdC) apparaît dans ma solution SAP Ariba Procurement, mais pas dans mon système Enterprise Resource Planning (ERP).


Cause

La demande de création du bon de commande a été envoyée au système ERP, mais la solution d'approvisonnement n'ayant jamais reçu de réponse, la demande d'achat est bloquée au statut Commande en cours.


Résolution

Option 1 : renvoi des bons de commande

Si vous utilisez Service Web (WS) ou la passerelle gérée SAP Integration Suite pour une intégration des bons de commande basée sur la gestion des dépenses et SAP Business Network, vous pouvez utiliser la fonctionnalité Renvoi amélioré des bons de commande bloqués à l'état Commande en cours ou Annulation en cours pour renvoyer le bon de commande.

Option 2 : importation de l'erreur de transmission au système ERP

Une autre option consiste à utiliser la méthode d'Importation de l'erreur de transmission au système ERP pour importer une erreur ERP et renvoyer la demande d'achat au statut Composition en cours, qui en autorise la suppression. Cette option peut également être utilisée pour le canal de fichiers.

  1. Dans votre solution d'approvisionnement, cliquez sur Gérer > Administration centrale > Importation/Exportation de données.
  2. Recherchez Importer les statuts des bons de commande ou Importer les erreurs liées aux bons de commande.
  3. Cliquez sur Importer.
  4. Cliquez sur Parcourir et sélectionnez le fichier CSV (valeurs séparées par des virgules) contenant l'erreur.
  5. Cliquez sur Exécuter.
  6. Accédez à la demande d'achat. Une nouvelle version de cette demande d'achat est disponible au statut Composition en cours.
  7. Cliquez sur le bouton Annuler la modification.
  8. Le bouton Supprimer doit maintenant apparaître.

N'utilisez pas cette méthode pour les bons de commande déjà créés dans votre système ERP, mais bloqués au statut Commande en cours, car ils n'ont pas atteint SAP Business Network.

Option 3 : forcer la commande

Une autre méthode consiste à utiliser l'option Forcer la commande pour faire passer le BdC au statut Commandé, à annuler la commande, puis à utiliser Forcer l'annulation pour faire passer le BdC au statut Annulé. Cette action ne supprime pas le bon de commande, mais a pour effet de terminer le workflow de la demande d'achat/du bon de commande. Cela fonctionne tel quel pour le canal de fichiers, mais pour l'intégration WS ou ISMG (CIG), vous devez d'abord activer le paramètre Application.Purchasing.AllowForceCancelForForceOrderedERPOrders, sinon il ne sera pas possible d'annuler la commande. Cette méthode n'est généralement pas recommandée, mais elle est possible.

  1. Dans votre solution d'approvisionnement, cliquez sur Gérer > Bons de commande.
  2. Recherchez le bon de commande par ID de demande d'achat (voir Comment obtenir le numéro EP de la commande pour une demande d’achat bloquée à l’étape "Commande en cours" ? si vous avez besoin d'aide pour rechercher un bon de commande).
  3. Cliquez sur le lien hypertexte de l'intitulé du BdC.
  4. Cliquez sur Forcer la commande, ajoutez des commentaires et cliquez sur OK.
  5. Pour annuler la demande d'achat / le bon de commande, suivez les étapes 1 à 3, puis cliquez sur Annuler.
  6. Une nouvelle version de la demande d'achat est créée à ce stade et, si aucune procédure d'approbation n'est configurée, le bon de commande / la demande d'achat passe au statut Annulation en cours. Cliquez sur Forcer l'annulation sur la commande.

Notez que si l'option Forcer la commande est utilisée, toutes les futures opérations en lien avec la commande ne sont pas prises en charge.


Voir également

Vous pouvez vérifier le type d'intégration en suivant ces étapes :

  1. Dans votre solution d'approvisionnement, cliquez sur Gérer > Administration centrale > Gestionnaire d'intégration.
  2. Cliquez sur Configuration de l'intégration.
  3. Recherchez Exporter les bons de commande.
  4. Sous la colonne Format , vérifiez si Canal de fichiers, Service Web ou Passerelle gérée pour Spend & Network est affiché.

Pour la méthode d'importation de l'erreur de transmission au système ERP, la configuration suivante est requise :

Si votre bon de commande a atteint le statut Échec définitif, découvrez comment résoudre ce problème ici.



S'applique à

Achats > Bons de commande
Achats > Demande d'achat
Passerelle gérée SAP Integration Suite > Passerelle gérée pour Approvisionnement

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