Nota de suporte KB0393753
E-mail
Um pedido de compra falha com uma mensagem de erro “PO-9: Resposta de cXML inválida”
Sintoma

While sending a Purchase Order to SAP Business Network, my purchase order fails with the below error: PO-9: Invalid cXML response.


Causa

The supplier's commerce eXtensible Markup Language (cXML) application is sending back an invalid cXML response for the order posted by Ariba.

The following is an example of an invalid cXML response:

<?xml version="1.0" encoding="UTF-8" ?><!DOCTYPE cXML SYSTEM "http://xml.cxml.org/schemas/cXML/1.1.010/cXML.dtd"><Response>
<Status code="500" text="Unrecognised message request"/>
</Response>


Resolução
Problema

Um pedido de compra falha com uma mensagem de erro PO-9: Resposta de cXML inválida.

Causa

O aplicativo commerce eXtensible Markup Language (cXML) do fornecedor envia de volta uma resposta cXML inválida para o pedido publicado pela Ariba.

Exemplo de uma resposta cXML inválida:

http://xml.cxml.org/schemas/cXML/1.1.010/cXML.dtd">
  

Solução

O aplicativo do fornecedor precisa enviar de volta uma confirmação 200 válida para o pedido publicado pela Ariba.

Exemplo de uma resposta 200 válida:

http://xml.cXML.org/schemas/cXML/1.2.021/cXML.dtd"> <cXMLpayloadID="1232424-2001@premier.workchairs.com"xml:lang="en-CA"  timestamp="2016-10-12T18:39:42-08:00">

   

 


Veja também

See Purchase orders are failing to reach the supplier integrated system (via cXML), but can be seen in the supplier's Inbox for a list of common similar errors and their resolution.



Aplicável a

SAP Business Network para compras e cadeia de suprimentos > Documentos de transação > Transação (pedidos de compra, avisos de entrega e recibos de mercadorias)

Termos de uso  |  Copyright  |  Divulgação de segurança  |  Privacidade