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Por que um pedido de compra falhou com o Erro: PO-9: resposta cXML inválida?
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Sintoma

Um pedido de compra (PO) enviado para o SAP Business Network falha com o erro PO-9: resposta cXML inválida


Ambiente

SAP Business Network


Causa

O aplicativo Commerce eXtensible Markup Language (cXML) do fornecedor está retornando uma resposta cXML inválida para o pedido de compra enviado pelo SAP Business Network.

Abaixo está um exemplo de uma resposta inválida desse tipo:

<?xml version="1.0" encoding="UTF-8" ?><!DOCTYPE cXML SYSTEM "http://xml.cxml.org/schemas/cXML/1.1.010/cXML.dtd"> <Resposta>
<Código de status="500" text="Texto de amostra"/>
</Resposta>


Resolução

Para garantir a transmissão com êxito do pedido de compra, o sistema do fornecedor deve retornar uma confirmação HTTP 200 válida quando o SAP Business Network encaminhar o pedido de compra.

Além disso, a resposta cXML deve seguir rigorosamente o formato descrito na seção Documento de resposta de exemplo do Guia de soluções cXML. A não conformidade com este formato pode resultar na marcação do pedido como Falha no SAP Business Network.

Abaixo está um exemplo de uma resposta 200 válida:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE cXML SYSTEM "http://xml.cXML.org/schemas/cXML/1.2.021/cXML.dtd">
<cXML payloadID="1232424-testpayloadid234525" xml:lang="en-CA" timestamp="2016-10-12T18:39:42-08:00">
<Resposta>
<Código de status="200" text="OK"/>
</Resposta>
</cXML>

Como alternativa, se a integração cXML não for necessária ou estiver configurada incorretamente, você poderá alterar o método de encaminhamento no SAP Business Network, navegando para: Configurações da conta (iniciais do usuário) > Configurações > Encaminhamento de pedidos eletrônicos e selecionando uma opção alternativa (por exemplo, On-line).

Assim que a ação de correção apropriada tiver sido executada, o fornecedor pode reenviar o pedido de compra para si mesmo para atualizar o respectivo status para Confirmado. Se o fornecedor puder enviar uma fatura para a ordem de compra, o status da ordem de compra também será atualizado para Confirmado.


Veja também

SAP Help Portal > SAP Business Network for Procurement > Guia de soluções cXML > Pedidos de compra > Documentos de resposta

KB0404685 - Os pedidos de compra (PO) não estão chegando ao sistema integrado do fornecedor (via cXML), mas podem ser vistos na caixa de entrada do fornecedor

KB0558349 - Como reenvio o pedido de compra de uma conta de fornecedor?



Aplicável a

SAP Business Network para compras e cadeia de suprimentos > Documentos de transação > Transação (pedidos de compra, avisos de entrega e recibos de mercadorias)

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