Note d'assistance KB0393753
E-mail
Un bon de commande est en échec avec un message d’erreur "PO-9 : réponse cXML non valide".
Symptôme

While sending a Purchase Order to SAP Business Network, my purchase order fails with the below error: PO-9: Invalid cXML response.


Cause

The supplier's commerce eXtensible Markup Language (cXML) application is sending back an invalid cXML response for the order posted by Ariba.

The following is an example of an invalid cXML response:

<?xml version="1.0" encoding="UTF-8" ?><!DOCTYPE cXML SYSTEM "http://xml.cxml.org/schemas/cXML/1.1.010/cXML.dtd"><Response>
<Status code="500" text="Unrecognised message request"/>
</Response>


Résolution
Problème

Un bon de commande est en échec avec un message d’erreur PO-9 : réponse cXML non valide.

Cause

L’application cXML (commerce eXtensible Markup Language) du fournisseur renvoie une réponse cXML non valide pour la commande envoyée par Ariba.

Voici un exemple de réponse cXML non valide :

http://xml.cxml.org/schemas/cXML/1.1.010/cXML.dtd">
  

Solution

L’application du fournisseur doit envoyer un accusé de réception valide 200 pour la commande envoyée par Ariba.

Voici un exemple de réponse 200 valide :

http://xml.cXML.org/schemas/cXML/1.2.021/cXML.dtd"> <cXMLpayloadID="1232424-2001@premier.workchairs.com"xml:lang="en-CA"  timestamp="2016-10-12T18:39:42-08:00">

   

 


Voir également

See Purchase orders are failing to reach the supplier integrated system (via cXML), but can be seen in the supplier's Inbox for a list of common similar errors and their resolution.



S'applique à

SAP Business Network for Procurement & Supply Chain > Documents de transaction > Transaction (bons de commande, avis d'expédition et reçus de marchandises)

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