Nota de asistencia técnica KB0393753
Correo electrónico
Falló un pedido de compra con el mensaje de error "PO-9: Respuesta cXML no válida"
Síntoma

While sending a Purchase Order to SAP Business Network, my purchase order fails with the below error: PO-9: Invalid cXML response.


Causa

The supplier's commerce eXtensible Markup Language (cXML) application is sending back an invalid cXML response for the order posted by Ariba.

The following is an example of an invalid cXML response:

<?xml version="1.0" encoding="UTF-8" ?><!DOCTYPE cXML SYSTEM "http://xml.cxml.org/schemas/cXML/1.1.010/cXML.dtd"><Response>
<Status code="500" text="Unrecognised message request"/>
</Response>


Resolución
Problema

Falló un pedido de compra con el mensaje de error PO-9: Respuesta cXML no válida.

Motivo

La aplicación de commerce eXtensible Markup Language (cXML) del proveedor está enviando una respuesta cXML no válida al pedido publicado por Ariba.

El siguiente ejemplo es de una respuesta cXML no válida:

http://xml.cxml.org/schemas/cXML/1.1.010/cXML.dtd">
  

Solución

La aplicación del proveedor debe enviar una confirmación de código 200 válida para el pedido publicado por Ariba.

El siguiente ejemplo es de una respuesta de código 200 válida:

http://xml.cXML.org/schemas/cXML/1.2.021/cXML.dtd"> <cXMLpayloadID="1232424-2001@premier.workchairs.com"xml:lang="en-CA"  timestamp="2016-10-12T18:39:42-08:00">

   

 


Ver también

See Purchase orders are failing to reach the supplier integrated system (via cXML), but can be seen in the supplier's Inbox for a list of common similar errors and their resolution.



Se aplica a

SAP Business Network for Procurement & Supply Chain > Documentos de transacción > Transacción (Pedidos de compra, avisos de expedición y entrada de mercancías)

Condiciones de uso  |  Copyright  |  Declaración de seguridad  |  Privacidad