Nota de asistencia técnica KB0393294
Correo electrónico
El pedido de compra falla en SAP Business Network con el error "PO-7: Respuesta cXML recibida que indica un error temporal"
Este artículo de la base de conocimientos ha sido traducido automáticamente para su comodidad. SAP no ofrece ninguna garantía con respecto a la exactitud o integridad de la traducción automática. Puede acceder al contenido original si cambia al inglés mediante el selector de idiomas.
Síntoma

Se ha recibido un pedido de compra en SAP Business Network, pero ha fallado y no ha llegado al sistema integrado del proveedor mediante cXML. En la pestaña Histórico de pedido hay el siguiente error:

PO-7: Respuesta cXML recibida que indica un error temporal.


Causa

Se ha recibido una respuesta con un código de estado de serie 5xx que indica que se ha recibido un error temporal del sistema de compras del proveedor.


Resolución

Se debe enviar una respuesta con un código de estado de serie 2xx que indique que el pedido se ha confirmado correctamente desde el sistema de compras del proveedor. A continuación se muestra un ejemplo de una respuesta válida:

<?xml version="1.0" coding="UTF-8"?>
<!DOCTYPE cXML SYSTEM "http://xml.cXML.org/schemas/cXML/1.2.021/cXML.dtd">
<cXMLpayloadID="testpayload123"xml:lang="en-US" timestamp="2019-11-14T18:39:42-08:00">
<Respuesta>
<Código de estado="200" text="OK"/>
</Respuesta>
</cXML>

Información adicional

Consulte Los pedidos de compra no llegan al sistema integrado del proveedor (mediante cXML), pero se pueden ver en la Bandeja de entrada del proveedor para obtener una lista de errores similares comunes y su resolución.



Se aplica a

SAP Business Network for Procurement & Supply Chain > Documentos de transacción > Transacción (Pedidos de compra, avisos de expedición y entrada de mercancías)
SAP Business Network for Procurement & Supply Chain > SAP Business Network Integrations > Pedidos CXML

Condiciones de uso  |  Copyright  |  Declaración de seguridad  |  Privacidad