Nota de asistencia técnica KB0392513
Correo electrónico
No se puede modificar una solicitud de pedido (PR) o un pedido de compra (PO)
Síntoma

No veo el botón Modificar en una solicitud de pedido (PR) o en un pedido de compra (PO).

Veo el botón Modificar en una solicitud de pedido o en un pedido de compra, pero recibo un mensaje de error cuando hago clic en él.

No puedo modificar una solicitud de pedido o un pedido de compra.


Causa

No es posible modificar un pedido de compra si se produce alguna de estas situaciones:

Del mismo modo, no puede modificar una solicitud de pedido si se cumple alguna de las condiciones anteriores para cualquiera de los pedidos de compra asociados.


Resolución
  1. Compruebe que el parámetro editable por el cliente Application.Procure.AllowChangeRequisition esté establecido en .
  2. A continuación, si el pedido de compra tiene productos de mercado o si la solicitud asociada tiene datos de activos, no puede modificar el pedido de compra. Debe crear un pedido de compra nuevo.
  3. Si ya existe una solicitud de modificación, realice cualquier cambio en esa solicitud de pedido directamente y envíela.
  4. Si el pedido de compra aún no se ha pedido, use la tarea de integración Importar estado de pedido de compra para importar un ID para cambiar el estado del pedido de compra a Pedido. A continuación, intente modificar el pedido de compra de nuevo.
  5. Si no es el Solicitante o el Preparador de la solicitud de pedido, asegúrese de que su usuario esté en el grupo Administrador de compras o en uno de los grupos secundarios, como Administrador de aprovisionamiento.

Si el pedido de compra tiene uno de los estados siguientes:

  1. Actualice los parámetros apropiados e intente cambiar el pedido de compra de nuevo.
  2. Si la ubicación del proveedor asociada con el pedido de compra tiene restricciones de orden de modificación, actualice la ubicación del proveedor si corresponde e intente cambiar el pedido de compra de nuevo.
  3. Si el pedido de compra es una orden de liberación, asegúrese de que el contrato esté abierto o que ambos de los siguientes sean ciertos:

Si está intentando modificar una solicitud de pedido, verifique la configuración anterior para todos los pedidos de compra asociados.

Si alguno de los pedidos de compra asociados con la solicitud de pedido no se puede modificar, tampoco podrá modificar la solicitud de pedido.

Si necesita más ayuda, póngase en contacto con el servicio de asistencia de SAP.



Se aplica a

Compras > Pedidos de compra
Compras > Pedidos de compra > Modificar pedidos

Condiciones de uso  |  Copyright  |  Declaración de seguridad  |  Privacidad