Информация от службы поддержки 192493
Электронная почта
Не выполнено: статус закрытия заказа не отправлен во внешнюю систему
Для Вашего удобства эта статья базы знаний переведена машинными средствами. SAP не предоставляет никаких гарантий правильности или полноты машинного перевода. Исходное содержимое можно увидеть, переключившись на английский язык с помощью селектора языка.
Проблема

При закрытии заказа на покупку, действии пользователя или автоматически происходит сбой, и в истории отображается сообщение об ошибке: Статус закрытия заказа не был отправлен во внешнюю систему, а в столбце Действие указано Ошибка.

Время операции закрытия заказа Статус закрытия заказа был отправлен во внешнюю систему, и сбой находится в одной и той же минуте, или на пару минут друг от друга, в большинстве случаев это не более 2 минут, но это определенно не через часы.

Кроме того, статус Закрыть заказ не передается во внешнюю систему (систему ERP).

Причина

Этот сбой указывает на то, что Ariba попыталась, но не смогла экспортировать состояние закрытия заказа во внешнюю систему.

Это может быть вызвано следующими причинами:

Разрешение

Можно снова закрыть заказ вручную и проверить, работает ли он, если он не работает, см. следующие шаги в разделе Дополнительная информация для изучения основной причины. После определения и фиксации основной причины можно повторить попытку закрытия операции.

Дополнительная информация

Порядок анализа основной причины:

  1. Найдите затронутый заказ и откройте его.
  2. Перейдите на вкладку История.
  3. Найдите, что статус Close Order был отправлен записи внешней системы и записи Failed.
  4. Сравните время, чтобы убедиться, что здесь анализируется случай, разница должна составлять около 2 минут, в большинстве случаев это меньше.
  5. Запишите метку времени ошибки в формате ДД:ММ:ГГГГ ЧЧ:ММ AM/PM.
  6. Теперь вы можете оставить заказ, нажать на логотип, вверху справа, или просто вернуться из заказа.
  7. В правом верхнем углу щелкните Управление.
  8. В раскрывающемся списке выберите Базовое администрирование.
  9. Найдите и щелкните Диспетчер сайтов.
  10. Нажмите Импорт/экспорт данных.
  11. Щелкните Статус веб-сервиса.
  12. Найдите Экспортировать состояние закрытия заказа на покупку.
  13. Нажмите Просмотреть.
  14. Заполните поля " и "По" соответствующими значениями
    • Значения должны включать записанную метку времени
    • Добавление окна за 10 минут хорошо, но вернет слишком много результатов для просеивания.
    • 2-3 минуты, которые начинаются до и заканчиваются после метки времени «Неудача», обычно работают, если нет, увеличиваются на минуту.
  15. После настройки времени нажмите Поиск.
  16. Один или иногда несколько возвращаемых результатов будут иметь значение Ошибка в столбце статуса, и метка времени будет соответствовать сбою.
  17. Щелкните Просмотреть рядом с соответствующим сообщением об ошибке.
  18. Перейдите на вкладку Сведения об ошибке.
  19. В столбце Сообщение об ошибке вы увидите, что Ariba видит при попытке экспорта состояния Закрыть заказ.

Что делать с сообщением об ошибке?

Как только исследование определит проблему и устранит ее, можно попробовать предложенный подход в разделе Решение выше.


Применимо к

SAP Ariba Buying and Invoicing

Условия использования  |  Авторские права  |  Безопасность  |  Конфиденциальность