Support Note KB0404709
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Failed: Close Order status was not sent to the external system
Issue

When a Purchase Order (PO) is closed, by user action or automatically, it fails and shows the error message in history: Close Order status was not sent to the external system and under the Action column it says Failed.

The timing of the close order action Close Order status was sent to the external system and the failure is at the same minute, or a couple of minutes apart, in most cases it's no more than 2 minutes, but it's definitely not in hours.

Also, the Close Order status is not interfaced to the external system (ERP System).

Cause

This failure indicates that Ariba tried, but was unable, to export the Close Order status to the external system.

This could be caused by:

Resolution

You can close the Order again manually and check if it works, if it doesn't, please refer to the below steps, under Additional Information, to investigate the root cause, once the root cause is identified and fixed, you can attempt the close action again.

Additional Information

How to investigate the root cause:

  1. Search for the impacted Order, and open it.
  2. Click on the History tab.
  3. Find the Close Order status was sent to the external system entry & the Failed entry.
  4. Compare the times, to ensure it's the case analyzed here, the difference should be around 2 minutes, in most cases it's less.
  5. Note down the timestamp of the Failed, in the format DD:MM:YYYY HH:MM AM/PM.
  6. Now you can leave the Order, click on the logo, top right, or simply back out of the Order.
  7. Click Manage from the top right corner.
  8. Click Core Administration from the drop down list.
  9. Find and click Site Manager.
  10. Click Data Import/Export.
  11. Click on Web Service Status.
  12. Search for Export Purchase Order Close Status.
  13. Click on View.
  14. Populate the From & To fields with appropriate values
    • The values should be inclusive of the noted down timestamp
    • Adding a 10 minutes window is good, but will return too many results to sift through.
    • 2-3 minutes that start before and end after the "Failed" timestamp usually works, if not, increase by a minute.
  15. Once the times are set, click Search.
  16. One, or sometimes more, of the results that return will have Error under the status column, and the timestamp will match the failure.
  17. Click View next to the matching Error message.
  18. Click on the Error Details tab.
  19. Under the Error Message column you'll see what Ariba sees when attempting to export the Close Order status.

What to do with the error message?

Once the investigation identifies the problem and fix it, you can try the proposed approach in the Resolution section above.


Applies To

Purchasing

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