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オーダーの終了の失敗
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問題

オーダーを終了しようとすると、履歴に Failed: Close Order status was not sent to the external system というエラーが表示され、終了ステータスが Enterprise Resource Planning (ERP) システムにエクスポートされません。

原因

これは、オーダーの終了状況をエクスポートできるタスクがないためです。

この場合、Ariba システムはそのファイルをファイルチャネルに初期値設定しますが、引き続きエクスポートすることはできません。オーダーは、行った設定に基づいて、終了状況の外部システムからの確認待ちのままになります。

もう 1 つの考えられる原因は、終了状況をエクスポートするように Cloud Integration Gateway (CIG) を設定していても、[統合マネージャ] -> [Cloud Integration Gateway] でタスクが有効化されていないことです。 

ソリューション

タスクが有効化されていないことを確認できるため、ファイルチャネルタスク [注文書の終了状況をエクスポートする] に初期設定されます。

このフラグを削除するには、手動インポートタスク [注文書終了状況をインポートする] を使用して、成功した確認または失敗を手動でインポートします。

インポートするファイルの選択は、ビジネスプロセスおよびオーダーの要件によって異なります。たとえば、オーダーが ERP で開かれており、SAP Ariba で終了している場合は、エラー応答をインポートして状況を [未処理] に戻し、SAP Ariba と ERP の両方が同期されるようにすることができます。

ファイルチャネルインポート用に CSV ファイルを手動で作成する方法に関するガイダンスについては、記事「手動インポート用の CSV ファイルを作成する方法を教えてください。」を参照してください。

追加情報

この問題を回避するには、ファイルチャネル、CIG、または WS (Web サービス) に対して、[注文書終了状況をインポートする] タスクが少なくとも 1 つ有効化されていることを確認します。

CIG が設定されている場合は、[統合マネージャ] -> [Cloud Integration Gateway] のタスクの一覧からタスク自体が有効化されていることを確認してください。


該当項目

SAP Ariba Buying and Invoicing

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