Support Note KB0404474
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What Causes Docusign to Error with: "Failed to Acquire the Lock.."
Issue

User is receiving the following error from Docusign: Failed to acquire the lock because the envelope status was not created, sent or delivered.

Resolution

Since the error is taking place in DocuSign's UI, discard the envelope from DocuSign, which withdraws the task on SAP Ariba's end, then start a New Round of the task. The task will need to be submitted as Paper Signature, if the error is encountered again: How do I complete or replace an electronic signature task with a paper signature?

Cause

The root cause of the error is when a user creates a Signature Task and is punched-in from SAP Ariba to DocuSign, the envelope being worked on for signature is in a Created state. UpdateSignatureTasksTask is the system task that communicates with DocuSign. If task starts running before the user completes the signature task set up (i.e. adding signers, signature fields and other field properties) and clicks Send, Ariba sends a void request to DocuSign to cancel/withdraw the envelope.

Additional Information

Check for the site parameter: SignatureTaskRefreshInterval is set to 10 minutes but can be set to 20 minutes. For example, the UpdateSignatureTasksTask will run every 20 minutes, and follows an average runtime-duration of around 22 seconds. Meaning, this error can only happen if someone is punched into DocuSign creating a signature task for that 22 second window that opens every 20 minutes.

Check which interval your realm is set, and have it increased.
10 means 10 minutes, thus by updating it to 20, the maximum replication time for your signed document back to Ariba would be 20 minutes. However, you can override this by manually refreshing the Signature Task via Properties and Actions.


Applies To

Strategic Contracts > Contract Tasks

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