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Como processar recibos que não estão sendo enviados para o ERP?
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Problema

Os recibos são criados na Ariba, no entanto, eles não estão conseguindo enviar para o ERP (sistema externo) devido a erros de push de ERP. Alguns deles são recibos negativos (recibos de reversão) e também estão falhando.

Solução

Entendendo o fluxo de trabalho de recibos:

Em situações em que o erro não pode ser corrigido, podemos recomendar as abordagens abaixo:

Opção 1:
Forçar o processamento do recibo no Ariba, usando o botão Forçar processo no cabeçalho do recibo. Em seguida, crie o recibo manualmente no ERP. Essa abordagem é a recomendada, pois é mais simples e simples.

Opção 2:
Se a criação manual de entradas não for permitida e entrar em conflito com seus processos empresariais, você pode tentar o seguinte.

  • Forçar o processamento dos recibos parados (aquele que recebe erros de push de ERP).
  • Crie um novo recibo que estornará o recibo parado: se o primeiro recibo tiver a quantidade 1, o recibo de estorno deverá ter a quantidade -1; e vice-versa.
  • Certifique-se de que o novo recibo também recebe um Erro de push de ERP (sugestão: marcar Entrega concluída ou fechar o pedido para recebimento no ERP, não Ariba, pode ajudar).
  • Depois disso, o novo recibo de reversão também deve ser Forçar processamento.
  • Isso deixará o pedido na Ariba com 2 recibos se cancelando mutuamente.
  • Agora você precisa garantir que qualquer novo recibo criado fluirá com êxito para o ERP e, em seguida, criar um novo recibo.

Atenção: isso deve ser testado primeiro, uma vez que não será aplicável se alguma etapa for perdida ou se houver recebimento complexo executado no pedido. Também é importante entender a lógica por trás dela e pode variar com base na resposta do ERP. Por exemplo, se o ERP aceitar o recibo negativo e o lançar em vez de devolver o erro, essa abordagem não poderá ser seguida.

Opção 3:
A terceira abordagem é editar o Recibo com erro de push do ERP e definir o Valor aceito/Número aceito como 0 e reenviar. No entanto, você deve usar o botão de opção Fechar pedido no recibo, pois o sistema não permite o envio de um recibo com quantidade/valor de 0, a menos que você esteja fechando o pedido. Observe que você ainda pode reabrir o pedido de compra.

Atenção: não use essa abordagem se houver novos Recibos lançados em relação ao Pedido. Mesmo que estejam no estado Processado e exportados para ERP, o sistema remove os mesmos. Esta opção também não é possível se seu site estiver ativado para o fechamento no nível da linha do pedido de compra.

Causa

A causa dos erros precisa ser investigada no ERP, uma vez que o ERP está enviando de volta os erros por algum motivo específico. Caso o erro seja identificado como sendo algumas informações ausentes que estão sendo enviadas (não enviadas neste caso) da Ariba, você precisará fornecer as informações que o ERP espera que esteja no recibo.

Se o erro for causado pelo pedido não ser encontrado no ERP, certifique-se de que o pedido não foi Forçar pedido ou excluído no ERP depois de ter sido enviado da Ariba. As operações futuras não são suportadas para pedidos forçados, consulte o documento Transmissão do pedido e pedidos com falha.

Informações adicionais

Para ler mais sobre documentações específicas sobre recebimento, consulte abaixo:


Aplicável a

SAP Ariba Buying and Invoicing

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