Support Note KB0403226
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How do I resolve receipts that are failing to send to my ERP?
Symptom

Receipts (as well as negative/ reverse receipts) are created in SAP Business Network but are failing due to ERP Push Error.


Cause

When receiving an ERP Push error, investigate within your external procurement solution to find out if information is missing or incomplete.

If the error is because the order can't be found in your ERP, ensure that the order wasn't Force Ordered or deleted on the ERP after it was sent from SAP. Future operations aren't supported for forced orders, refer to document Order transmission and failed orders.


Resolution

Understanding receipt workflow:

In situations where the error cannot be fixed, we recommend the below approaches:

Option 1 (recommended):
Force Process the receipt using the Force Process button on the receipt's header. Then create the receipt manually on ERP.

Option 2:
If manual creation of receipts is not allowed or not possible:

Caution: Test first to ensure no step is missed, or if there's complex receiving performed on the order. It is important to understand the logic and can vary based on the ERP response. For instance, if ERP accepts the negative receipt and posts it instead of sending back error, this approach cannot be followed.


Option 3:
Edit the receipt with ERP Push Error and set the Amount Accepted/Number Accepted as 0 and resubmit. Use the Close Order button on the receipt (the order may still be reopened).

Caution: Do not use this option if there are any new receipts posted against the order. Even if they are in Processed state and exported to ERP, they will be removed. This option is also not possible if your site is enabled for Purchase Order line level closure.


See Also

To further read about specific documentations about receiving, please refer below:



Applies To

Purchasing > Receiving
Purchasing > Receiving > Receipt Import/Export

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