Support Note KB0396374
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Purchase Requisition is stuck in Ordering status
Symptom

My Purchase Requisition (PR) is stuck in Ordering status, and the Purchase Order (PO) appears in my SAP Ariba Procurement solution, but not in my Enterprise Resource Planning (ERP) system.


Environment

SAP Ariba Buying


Cause

The PO creation request was sent to the ERP or (Ariba Business Network) AN, but the procurement solution never received a response, so the PR is stuck in Ordering status.


Resolution

If you use Web Service (WS), or SAP Integration Suite Managed Gateway for Spend Management and SAP Business Network based integration for POs, you can use SAP Help Portal: Enhanced Resending of Purchase Orders Stuck in Ordering or Canceling State feature to resend the PO.

Another option is to use ERP Push Error Import to import an ERP error to move the PR back to Composing status, which will allow deleting the PR. This option can also be used for file channel.

  1. In your procurement solution, click Manage > Core Administration > Data Import/Export.
  2. Search for either Import Purchase Order Status or Purchase Order Error Import.
  3. Click Import.
  4. Click Browse, and select the Comma-Separated Values (CSV) file containing the error.
  5. Click Run.
  6. Go to the PR. A new version of it will be available in the Composing status.
  7. Click the Undo Change button.
  8. The Delete button should now appear.

Do not use this method for POs that are already created in your ERP but are stuck in Ordering status because they did not reach the SAP Business Network.

Another method is to use the Force Order option to move the PO to Ordered status, then cancel the order, then use Force Cancel to move it to Canceled status. This does not delete the PO, but ends the workflow of the PR/PO. This works as is for File Channel, but for WS or ISMG (CIG) integration, you must enable the parameter Application.Purchasing.AllowForceCancelForForceOrderedERPOrders (SAP Help Portal: Force cancel orders that are not sent to ERP systems) first, otherwise it will not be possible to cancel the order. This method is not recommended in general, but possible.

  1. In your procurement solution, click Manage > Purchase Orders.
  2. Search for the PO by Requisition ID (see KBA KB0404202: How do I get the Order's EP number for a requisition stuck in ordering? if you need help finding a PO).
  3. Click the PO title hyperlink.
  4. Click Force Order, add comments, and click OK.
  5. To cancel the PR/PO, follow steps 1-3, and then click Cancel.
  6. A new version of the PR is created at this point, and if there is no approval flow configured, the PO/PR is moved to Canceling status.
  7. Click Force Cancel on the order.

Note that using Force Order means that all future operations on the order will not be supported (SAP Help Portal: Order Transmission and Failed Orders).


See Also

You can check the integration type by following these steps:

  1. In your procurement solution, click Manage > Core Administration > Integration Manager.
  2. Click Integration Configuration.
  3. Search for Export Purchase Orders.
  4. Under the Format column, check whether it shows File Channel, Web Service, or Managed Gateway for Spend & Network.

For ERP Push Error Import, you will need the following:

If your PO has reached Permanently Failed status, see:



Applies To

Purchasing > Purchase Orders
Purchasing > Requisitioning
SAP Integration Suite Managed Gateway > Managed Gateway for Procurement

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