Support Note 167094
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Error: PO-11: Cannot deliver order. Terminal error code for PO status: Couldn't parse document
Issue

Purchase Orders (PO) are failing to reach the supplier integrated system. The PO History tab in Ariba Network shows the error message below:

Error: PO-11: Cannot deliver order. Terminal error code for PO status: Couldn't parse document?

Resolution

The supplier needs to review internally with their IT and integration team to learn why they are sending an invalid cXML response. For your POs not to be marked as Failed in Ariba Network, the supplier's integrated system need to send back a successful 200 status code.

Once the issue has been addressed, the supplier can resend the failed orders from their Ariba Network account.

Cause

The supplier's preferred order routing method is set to cXML, and their integrated system is returning an invalid cXML response.

One such example is an invalid cXML response having the entire PO cXML sent back with the response: 

<Response>
<Status code="500" text="PO item price: 0.0 does not match quote price: 191"
</Response>
Additional Information

See an example of a correct cXML response below:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE cXML SYSTEM "http://xml.cxml.org/schemas/cXML/1.2.014/cXML.dtd">
<cXML payloadID="994994" xml:lang="en" timestamp="2002-03-12T18:39:09-08:00">
<Response>
<Status code="200" text="OK"/>
</Response>
</cXML>

For additional information on cXML integration, see the cXML solutions guide.

See this list of common integration errors for a list of common similar errors and their resolution.


Applies To

SAP Business Network

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