Nota di supporto 144927
Posta elettronica
Un ordine d'acquisto non riesce con errore: "PO-9: risposta cXML non valida"
Per comodità dell'utente, questo articolo della Knowledge Base è stato tradotto automaticamente. SAP non fornisce alcuna garanzia in merito alla correttezza o alla completezza della traduzione automatica. È possibile visualizzare il contenuto originale passando all'inglese nel selettore della lingua.
Problema

Un ordine d'acquisto non riesce a causa del seguente errore:

PO-9: Risposta cXML non valida.

Risoluzione

L'applicazione del fornitore deve inviare una conferma valida di 200 per l'ordine pubblicato da Ariba.

Di seguito è riportato un esempio di una risposta valida di 200:

<?versione xml="1.0" codifica="UTF-8"?> <!DOCTYPE cXML SYSTEM "http://xml.cXML.org/schemas/cXML/1.2.021/cXML.dtd"> <cXML payloadID="1232424-2001@premier.workchairs.com"xml:lang="en-CA" timestamp="2016-10-12T18:39:42-08:00">
<Risposta>
<Codice stato="200" testo="OK"/>    
</Risposta> </cXML>

Causa

L'applicazione commerce eXtensible Markup Language (cXML) del fornitore sta inviando una risposta cXML non valida per l'ordine pubblicato da Ariba.

Di seguito viene riportato un esempio di risposta cXML non valida:

<?xml version="1.0" encoding="UTF-8" ?><!DOCTYPE cXML SYSTEM "http://xml.cxml.org/schemas/cXML/1.1.010/cXML.dtd"><Risposta>
   <Codice stato="500" testo="Richiesta messaggio non riconosciuta"/>
</Risposta>

Informazioni supplementari

Vedere Gli ordini d'acquisto non riescono a raggiungere il sistema integrato del fornitore (tramite cXML), ma possono essere visualizzati nella Posta in arrivo del fornitore per un elenco di errori simili comuni e la relativa risoluzione.


Si applica a

SAP Business Network

Condizioni di utilizzo  |  Copyright  |  Informazioni sulla sicurezza  |  Privacy