Support Note KB0393753
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Why a Purchase Order failed with the Error: PO-9: Invalid cXML response?
Symptom

A Purchase Order (PO) sent to the SAP Business Network fails with the error PO-9: Invalid cXML response


Environment

SAP Business Network


Cause

The supplier's Commerce eXtensible Markup Language (cXML) application is returning an invalid cXML response for the PO sent by SAP Business Network.

Below is an example of such an invalid response:

<?xml version="1.0" encoding="UTF-8" ?><!DOCTYPE cXML SYSTEM "http://xml.cxml.org/schemas/cXML/1.1.010/cXML.dtd"> <Response>
<Status code="500" text="Sample Text"/>
</Response>


Resolution

To ensure successful PO transmission, the supplier's system must return a valid HTTP 200 acknowledgment when SAP Business Network routs the PO.

Additionally, the cXML response must strictly follow the format outlined in the cXML Solutions Guide Example Response Document section. Failure to comply with this format may result in the PO being marked as Failed in the SAP Business Network.

Below is an example of a valid 200 response:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE cXML SYSTEM "http://xml.cXML.org/schemas/cXML/1.2.021/cXML.dtd">
<cXML payloadID="1232424-testpayloadid234525" xml:lang="en-CA" timestamp="2016-10-12T18:39:42-08:00">
<Response>
<Status code="200" text="OK"/>
</Response>
</cXML>

Alternatively, if cXML integration is not required or is currently misconfigured, you may change the routing method in SAP Business Network by navigating to: Account Settings (User Initials) > Settings > Electronic Order Routing, and selecting an alternative option (e.g., Online).

Once the appropriate corrective action has been taken, the supplier can resend the PO to themselves to update its status to Acknowledged. If the supplier is able to submit an Invoice to the PO, the PO status will also be updated to Acknowledged.


See Also

SAP Help Portal > SAP Business Network for Procurement > cXML Solutions Guide > Purchase Orders > Response Documents

KB0404685 - Purchase Orders (PO) are failing to reach the supplier integrated system (via cXML), but can be seen in the supplier's Inbox

KB0558349 - How do I resend Purchase Order from a supplier account?



Applies To

SAP Business Network for Procurement & Supply Chain > Transaction Documents > Transaction (Purchase Orders, Ship Notices & Goods Receipts)

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