Информация от службы поддержки KB0587644
Электронная почта
Пользователи сталкиваются с проблемами перенаправления и навигации в пошаговых покупках
Для Вашего удобства эта статья базы знаний переведена машинными средствами. SAP не предоставляет никаких гарантий правильности или полноты машинного перевода. Исходное содержимое можно увидеть, переключившись на английский язык с помощью селектора языка.
Симптом

При выполнении одного из следующих действий пользователи сталкиваются с проблемами перенаправления и навигации в пошаговых покупках в центре обработки данных Prod3:

  • Когда пользователи нажимают кнопку Выйти в пошаговых покупках, вместо выхода выполняется перенаправление на главную страницу пошаговых покупок.
  • Когда пользователи входят в пошаговые покупки через Single Sign-On (SSO), они не перенаправляются в пошаговые покупки, а перенаправляются в SAP Ariba Buying (B&I).
  • Когда пользователи используют плитки действий для перехода к B&I, любое действие, выполненное в B&I, перенаправляет пользователя обратно в пошаговые покупки.
  • Когда пользователь щелкает внутренние ссылки (например, "Просмотреть в SAP Ariba Procurement") для перехода к B&I, он отображается в ненормальном текстовом формате.

Причина

Для доступа к пошаговым покупкам через SSO используется неправильный URL домена или неправильный URL-адрес Ariba Buying или закупок, настроенный на плитке действия пошаговых покупок.

  1. Неверный домен s1.ariba.com вместо s3.ariba.com. Проверьте конфигурацию SSO и измените URL перенаправления SSO на s3.ariba.com вместо домена s1.ariba.com.
  2. Неверный URL в формате "https://[realm-name].procurement.ariba.com/..." вместо "https://[realm-name].procurement3.ariba.com/...". Или неверный формат "https://s1.ariba.com/..." вместо "https://s3.ariba.com/...".

Разрешение

Чтобы устранить эту проблему, проверьте следующее:

Важно! После внесения изменений в конфигурацию все затронутые пользователи должны выполнить следующие шаги, чтобы очистить кэш и разрешить им доступ к приложению:

  1. Откройте веб-браузер и очистите кэш.
  2. Закройте окно браузера.
  3. Повторно откройте окно браузера.
  4. Доступ к пошаговым покупкам по URL, содержащему procurement3.ariba.com.


Применимо к

Пошаговые покупки

Условия использования  |  Авторские права  |  Безопасность  |  Конфиденциальность