Nota de asistencia técnica KB0587644
Correo electrónico
Los usuarios se enfrentan a problemas de redireccionamiento y navegación en la compra guiada
Este artículo de la base de conocimientos ha sido traducido automáticamente para su comodidad. SAP no ofrece ninguna garantía con respecto a la exactitud o integridad de la traducción automática. Puede acceder al contenido original si cambia al inglés mediante el selector de idiomas.
Síntoma

Los usuarios se enfrentan a problemas de redireccionamiento y navegación en la compra guiada en el centro de datos de Prod3 al realizar una de las siguientes acciones:

  • Cuando los usuarios hacen clic en el botón Cerrar sesión en la compra guiada, se redirige a la página de inicio de la compra guiada en lugar de cerrar la sesión.
  • Cuando los usuarios inician sesión en la compra guiada mediante la identificación única (SSO), no se les redirige a la compra guiada, sino que se les redirige a SAP Ariba Buying (B&I).
  • Cuando los usuarios utilizan fichas de acción para navegar a B&I, cualquier acción realizada en B&I redirige al usuario de vuelta a la compra guiada.
  • Cuando el usuario hace clic en enlaces internos (como "Ver en SAP Ariba Procurement") para saltar a B&I, se muestra en un formato de texto anormal.

Causa

Se está utilizando una URL de dominio incorrecta para acceder a la compra guiada mediante SSO o una URL de Ariba Buying o Sourcing configurada de forma incorrecta en una ficha de acción de compra guiada.

  1. Dominio incorrecto como s1.ariba.com en lugar de s3.ariba.com. Verifique la configuración de SSO y asegúrese de cambiar la URL de redireccionamiento de SSO a s3.ariba.com en lugar de s1.ariba.com dominio.
  2. URL incorrecta porque el siguiente formato es "https://[realm-name].procurement.ariba.com/..." en lugar de "https://[realm-name].procurement3.ariba.com/...". O formato incorrecto como "https://s1.ariba.com/..." en lugar de "https://s3.ariba.com/...".

Resolución

Para mitigar este problema, verifique lo siguiente:

Importante: Después de realizar cambios en su configuración, haga que todos los usuarios afectados realicen los siguientes pasos para borrar su caché y permitirles acceder a la aplicación correctamente:

  1. Abra su navegador web y borre la caché.
  2. Cierre la ventana del navegador.
  3. Vuelva a abrir la ventana del navegador.
  4. Acceda a la compra guiada a través de una URL que contenga procurement3.ariba.com.


Se aplica a

Compra guiada

Condiciones de uso  |  Copyright  |  Declaración de seguridad  |  Privacidad