Support Note KB0587644
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Users are facing redirecting and navigation issues in Guided Buying
Symptom

Users are facing redirecting and navigation issues in guided buying in Prod3 Data center when performing one of the following:

  • When users are clicking on Log out in guided buying, it is redirecting to guided buying home page instead of logging out.
  • When users are Log in guided buying through single sign-on (SSO) they are not being redirected to guided buying instead they are redirecting to SAP Ariba Buying (B&I).
  • When users are using Action Tiles to navigate to B&I, any action performed in B&I redirects the user back to guided buying.
  • when user click internal links (like 'View in SAP Ariba Procurement') jump to B&I, the display is abnormal looks like text format.

Cause

Incorrect domain URL is being used to access Guided Buying through SSO or incorrect Ariba Buying or Sourcing URL configured in a Guided Buying Action Tile.

  1. Incorrect domain as s1.ariba.com instead of s3.ariba.com. Verify the SSO configuration and make sure to change the SSO redirect URL to s3.ariba.com instead of s1.ariba.com domain.
  2. Incorrect URL as the following format "https://[realm-name].procurement.ariba.com/..." instead of "https://[realm-name].procurement3.ariba.com/...". Or incorrect format as "https://s1.ariba.com/..." instead of "https://s3.ariba.com/..."

Resolution

To mitigate this issue verify the following:

Important: After you've made changes to your configuration, have all affected users take the following steps to clear their cache and allow for them to access the application successfully:

  1. Open your web browser and clear the cache.
  2. Close the browser window.
  3. Reopen the browser window.
  4. Access guided buying through a URL that contains procurement3.ariba.com.


Applies To

Guided Buying

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