サポートノート KB0408203
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状況が [オーダー中] のまま変わらない PO の逆シリアル化エラーを特定する方法
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現象

ERP システムで正しく承認および処理されると、購入申請 (PR) によって、支出および Network 向け管理ゲートウェイに表示される PurchaseOrderExportRequest のみが表示されて状況が [オーダー中] のままになっている注文書 (PO) が生成されます。


原因

この問題の一般的な原因の 1 つは、ERP で受信されるペイロードの予期しないコンテンツです。

支出および Network 向け管理ゲートウェイには、このシナリオに対するエラーハンドラがないため、SRT: シリアル化/逆シリアル化失敗 が原因であるかどうかを特定する唯一の方法は、ERP にアクセスして SRT_MONI トランザクションを調べることです。

エラー SRT: Serialization/Deserialization failed は、ABAP プロキシが XML を解析し、ABAP オブジェクトを入力しようとする逆シリアル化プロセスでトリガされます。この特定のシナリオでは、ペイロードのコンテンツが指定された長さ制限を超えているか、件名のフィールドに適していない文字が使用されており、エラーが発生します。


解決

ERP で SRT: シリアル化/逆シリアル化に失敗したことを特定するには、以下のステップを実行してください。

  1. ERP でトランザクションコード SRT_MONI にアクセスします。
  2. 結果出力で、詳細を選択します
  3. メッセージビューで技術ビューを選択します
  4. タイムスタンプ開始項目で、購買依頼が登録された日付を使用します。
  5. 処理ステータスグループ項目で、エラーを選択します
  6. Receiver Information > Interface Name use BuyerPurchaseOrderCreateRequest_Async_In and Execute (F8) が見つかるまで下にスクロールします。

購買担当者の購買発注 (PO) の登録依頼に関連する Web サービスユーティリティ: メッセージモニタに、すべてのエラーメッセージを含む画面が表示されます。

エラーメッセージが相関している伝票の問題を把握するには、以下の手順に従います。

  1. エラー情報 SRT: シリアル化/逆シリアル化失敗が表示されている行のエラー処理済アイコン () をクリックします。
  2. 画面の左側で、Message Body ( ) エレメントを探してクリックします。
  3. これで、 ---ERPORDERID フィールドを見つけて、支出および Network 向け管理ゲートウェイで PurchaseOrderExportRequest ドキュメントの名前を確認することができます。
  4. 項目 ----REQ_ID には、エラーメッセージの相関先である PR 番号が表示されます。

ペイロードのどのフィールドによってエラーがトリガされているかを確認するには、以下の手順に従います。

  1. エラー情報 SRT: シリアル化/逆シリアル化失敗が表示されている行のエラー処理済アイコン () をクリックします。
  2. 最初に項目 ----ChainedException を検索します。そのうちの 4 つがあることがわかります。
  3. メインエラーメッセージは、項目 ----Exception_Text 4 番目の -----ChainedException に表示されます

ペイロードの不適切なユーザデータに関連する最も一般的なタイプの逆シリアル化エラーは、以下のとおりです。

これらの問題を解決する方法は複数あり、最も一般的なものを以下に示します。

  1. Buying&Invoicing でドキュメントの新しいバージョンを作成して、オーダーの内容を変更し、支出および Network 向け管理ゲートウェイを介して再送信します。
  2. オーダーをキャンセルし、キャンセルされたオーダーをコピーし、エラーメッセージに記載されている制限を超えるフィールドを変更して新しいオーダーを作成し、支出および Network 向け管理ゲートウェイに再度提出します。
  3. 支出および Network 向け管理ゲートウェイで特定のフィールドの文字数を制限し、支出および Network 向け管理ゲートウェイでドキュメントを再処理するために、カスタムマッピングを作成します。
追加情報

特定の項目に対して再度発生しないように、カスタマイジング依頼を依頼することができます。これにより、Ariba ソリューションのフィールドの最大長が制限され、フィールドが正しく入力されなくなります。カスタマイジング依頼の詳細については、KB0537649 を参照してください。



該当項目

SAP Integration Suite 管理ゲートウェイ > Business Network 向け管理ゲートウェイ - SCC > Buyer Business Network 向け管理ゲートウェイ - SCC

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