Nota di supporto KB0408203
Posta elettronica
Modalità di individuazione di un errore di deserializzazione in un ordine d'acquisto bloccato in stato In ordinazione
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Sintomo

Dopo essere stata approvata ed elaborata correttamente dal sistema ERP, una richiesta di acquisto genera un ordine d'acquisto bloccato in stato di ordinazione con solo la PurchaseOrderExportRequest visualizzata nel gateway gestito per gestione della spesa e SAP Business Network.


Causa

Una delle cause comuni di questo problema è il contenuto imprevisto nel payload ricevuto dal sistema ERP.

Poiché il gateway gestito per gestione della spesa e SAP Business Network non dispone di un gestore di errori per questo scenario, l'unico modo per individuare se ciò è causato da un SRT: Serializzazione/Deserializzazione non riuscita avviene accedendo all'ERP e consultando la transazione SRT_MONI.

L'errore SRT: Serializzazione / Deserializzazione non riuscita viene avviato nel processo di deserializzazione in cui il proxy ABAP tenta di analizzare sintatticamente l'XML e alimentare gli oggetti ABAP. In questo particolare scenario, il contenuto nel payload supera un limite di lunghezza specificato o utilizza caratteri non adatti al campo nell'oggetto, avviando l'errore.


Risoluzione

Per individuare un SRT: Serializzazione / Deserializzazione non riuscita in ERP, eseguire i seguenti passi:

  1. Accedere al codice transazione SRT_MONI in ERP.
  2. In Output risultato selezionare Dettaglio.
  3. In View messaggio selezionare View tecnica.
  4. Nel campo Timestamp da utilizzare il giorno in cui è stata creata la RdA.
  5. Nel campo Gruppo di stati di elaborazione selezionare Errato.
  6. Scorrere verso il basso fino a trovare Receiver Information > Interface Name use BuyerPurchaseOrderCreateRequest_Async_In ed Execute (F8).

Ora verrà visualizzata una videata con tutti i messaggi di errore in Web Service Utilities: Message Monitor relativo alla richiesta di creazione di un ordine d'acquisto dell'acquirente.

Per comprendere a quale documento è correlato il messaggio di errore, attenersi alla seguente procedura:

  1. Fare clic sull'icona Errato () di qualsiasi riga visualizzata da Error Information SRT: Serialization / Deserialization.
  2. Sul lato sinistro della videata cercare l'elemento Corpo del messaggio ( ) e fare clic su di esso.
  3. Ora è possibile individuare il campo ---ERPORDERID per visualizzare il nome del documento PurchaseOrderExportRequest nel gateway gestito per gestione della spesa e SAP Business Network.
  4. Nel campo ----REQ_ID verrà visualizzato il numero PR a cui è correlato il messaggio di errore.

Per vedere quale campo nel payload sta causando l'errore:

  1. Fare clic sull'icona Errato () di qualsiasi riga visualizzata da Error Information SRT: Serialization / Deserialization.
  2. Cercare prima il campo ----Campo ChainedException, se ne noterà 4.
  3. Il messaggio di errore principale viene visualizzato nella quarta ----ChainedException nel campo -----Exception_Text.

I tipi più comuni di errore di deserializzazione relativi a dati utente impropri nel payload sono elencati di seguito:

Esistono diversi modi per risolvere questi problemi, quelli più comuni sono mostrati di seguito:

  1. Modificare il contenuto dell'ordine e inviarlo nuovamente tramite il gateway gestito per gestione della spesa e SAP Business Network creando una nuova versione del documento in Buying&Invoicing.
  2. Annullare l'ordine e crearne uno nuovo copiando quello annullato e modificando i campi che superano la limitazione menzionata nel messaggio di errore e inviarlo nuovamente al gateway gestito per gestione della spesa e SAP Business Network.
  3. Creare un mapping personalizzato nel gateway gestito per gestione della spesa e SAP Business Network per limitare il numero di caratteri nel campo specifico e rielaborare il documento nel gateway gestito per gestione della spesa e SAP Business Network.
Informazioni supplementari

Per evitare che accada di nuovo per qualsiasi campo particolare, è possibile richiedere una richiesta di personalizzazione. Ciò limiterà la lunghezza massima del campo nella soluzione Ariba, impedendo che venga compilato erroneamente. Per ulteriori informazioni sulla richiesta di personalizzazione, consultare KB0537649.



Si applica a

SAP Integration Suite, gateway gestito > Gateway gestito per Business Network Supply Chain Collaboration > Gateway gestito per Business Network Supply Chain Collaboration per compratori

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