Support Note KB0406471
Email
Error: "Ariba Client Automation software component was not properly set up"
Symptom

Error message raised when exporting an analytical report.

Error: Ariba Client Automation software component was not properly set up.

There are two likely causes:

1) Your Internet Explorer settings must allow downloading and running signed ActiveX controls. To make this change, in Internet Explorer:

2) When a security warning panel was presented asking if you would install and run "Ariba Client Automation ActiveX Control", you clicked "No". For Ariba Applications to run, you must click "Yes".


Cause

Some sites still require ActiveX for exporting reports to Microsoft Excel. The only browser that supports ActiveX is Microsoft Internet Explorer, which will no longer be supported by SAP Ariba as of December 31, 2021.


Resolution

You can configure your site so it doesn't require ActiveX for exporting reports to Microsoft Excel. Your Designated Support Contact (DSC) should log a Case asking to SAP Ariba Support to enable the following features:

Once ActiveX is disabled, exports to Excel will not automatically populate the pivots and charts in the standard templates. Users must open those tabs and refresh the objects. For more information, see How to export the current contents of the report pivot table to an Excel file


See Also

SAP Help Portal > SAP Ariba Procurement Solutions > Running Analytical Reports > Export of Reports to Excel or CSV Files > Exporting the Current Contents of the Report Pivot Table to an Excel File

These features should be enabled on demand by creating a case to SAP Ariba Support team (Analytical Reporting).



Applies To

Catalog Management
Invoicing
Purchasing
SAP Ariba Analysis Reporting
Strategic Contracts
Strategic Sourcing
Supplier Information & Performance Management
Supplier Lifecycle & Performance

Terms of Use  |  Copyright  |  Security Disclosure  |  Privacy