Perguntas frequentes KB0405759
E-mail
Quais são os erros mais comuns encontrados durante a importação de contratos anteriores?
Este artigo da base de conhecimentos foi traduzido automaticamente para sua conveniência. A SAP não fornece qualquer garantia em relação à exatidão ou completude da tradução automática. Você pode encontrar o conteúdo original alternando para inglês, usando o seletor de idioma.
Sintoma

Quais são os erros mais comuns encontrados durante a importação de contratos anteriores?

Como resolvo erros comuns de importação de contratos anteriores?


Resolução

A lista a seguir inclui os erros mais comuns encontrados ao importar contratos anteriores. Selecione o texto do erro para ir para a respectiva linha na tabela:

  1. FileNotFoundException: nome do arquivo (não existe tal arquivo ou diretório)
  2. Você não tem um modelo publicado chamado...
  3. O nome do modelo não é aplicável
  4. next() encontrou erro de análise de AQL: literal de string mal formada processando instrução...
  5. NoSuchElementException: nulo
  6. Usuário '' não encontrou erro (ou) usuário 'nulo' não encontrado (ou) de instâncias de ContractId com ='[BaseId]', um tem DocumentId [BaseId], mas outro tem (argumento ausente)
  7. Nome do campo não encontrado...
  8. Ignorando MONEY FIELD devido à exceção ParseException: não é possível localizar moeda com prefixo=$ e sufixo=null
  9. Erro ao salvar o conteúdo do arquivo para o documento ContractDocuments.csv: java.io.FileNotFoundException
  10. Exceção ao compactar diretório...
  11. Erro ao analisar "username@domain.com": o número de chaves de pesquisa não corresponde ao número de valores fornecidos.

A tabela a seguir

NºDepós.Erro Causa e solução
1FileNotFoundException: nome do arquivo (não existe tal arquivo ou diretório)

Causa:

  • O arquivo ZIP de importação legado foi criado a partir de uma pasta em vez dos documentos individuais.
    • Você deve criar o file de arquivo diretamente a partir dos arquivos CSV e quaisquer documentos adicionais que você planeje carregar. Se você adicionar os CSVs e outros documentos a uma pasta, crie o arquivo ZIP a partir da pasta, o processo de importação falhará.
  • Os nomes de arquivo mencionados em ImportProjectParameters.csv estão incorretos - os nomes devem estar de acordo com o nome ou formato de arquivo CSV padrão e fazem distinção entre maiúsculas e minúsculas.
  • Um ou mais dos 4 arquivos CSV estão em falta.
    • Cada arquivo ZIP de importação legado deve conter todos os arquivos CSV necessários.
    • Você ainda deve incluir ContractDocuments.csv e ContractTeams.csv, mesmo que os arquivos estejam vazios.
  • O arquivo ImportProjectParameters.csv está ausente.

Solução:

  1. Corrija os erros no arquivo ZIP ou nos respectivos arquivos.
  2. Tente importar novamente.

(Voltar à lista)

2Você não tem um modelo publicado chamado ...

Causa:

  • Esse erro ocorre quando o modelo mencionado em ImportProjectParameters.csv está Inativo ou não publicado (status Rascunho).

Solução:

  1. Reative e publique o modelo.
  2. Tente importar novamente.

Informações adicionais

(Voltar à lista)

3O nome do modelo não é aplicável

Causa:

  • O modelo mencionado tem uma condição de visibilidade definida nele, por isso não pode ser usado.

Solução:

  1. Crie uma nova versão do modelo.
  2. Remover a condição de visibilidade
  3. Publique a nova versão do modelo.
  4. Tente importar novamente.

Informações adicionais:

  • Recomendamos que seja criado um modelo vazio separado que pode ser usado somente para importar contratos anteriores.

(Voltar à lista)

4next() encontrou erro de análise de AQL: literal de string mal formada processando instrução...

Causa:

  • O arquivo de importação CSV contém uma quebra de linha em um dos valores de coluna indicados.

Solução

    1. Abra o arquivo CSV em um editor de texto simples.
    2. Localize os valores para a coluna mencionada no erro e remova a quebra de linha ou o espaço
    3. Salve suas modificações.
    4. Crie um novo arquivo ZIP de importação legado.
    5. Tente importar novamente.

Informações adicionais:

(Voltar à lista)

5NoSuchElementException: nulo

Causa:

  1. O texto em um dos campos no arquivo de importação CSV contém aspas duplas ("), muito provavelmente perto do fim da entrada.

Solução:

  1. Abra o arquivo CSV em um editor de texto simples.
  2. Localize as entradas da última linha importada com êxito.
  3. Na linha seguinte (a linha que corresponde ao erro), verifique as entradas para aspas duplas (").
  4. Remova as aspas duplas.
  5. Salve suas modificações.
  6. Crie um novo arquivo ZIP de importação legado.
  7. Tente importar novamente.

Informações adicionais

(Voltar à lista)

6O usuário '' não encontrou o erro ou

Usuário 'nulo' não encontrado ou

De instâncias de ContractId com ='[BaseId]', uma tem DocumentId [BaseId], mas outra tem (argumento ausente)

Causa:

  • Você reutilizou um dos arquivos CSV de uma importação legada anterior, mas inseriu menos linhas de dados.

Solução:

  1. Abra o arquivo CSV em um editor de texto simples.
  2. Vá para o final do arquivo e verifique se existem linhas que contenham somente vírgulas (,).
  3. Se houver, exclua essas linhas.
  4. Salve suas modificações.
  5. Crie um novo arquivo ZIP de importação legado.
  6. Tente importar novamente.

Informações adicionais:

(Voltar à lista)

7Campo FieldName não encontrado...

Causa:

  • O nome exclusivo de um dos campos usados como cabeçalho de coluna está incorreto. Ele começa com cus_FieldName.
  • Se o erro estiver indicando que 'Cliente' não existe, esse valor de cabeçalho precisa ser Fornecedor.

Solução:

  1. Abra cada arquivo CSV e revise os valores do cabeçalho da coluna.
    • Qualquer campo personalizado deve usar o valor do nome do campo (normalmente formatado como cus_FieldName), não o valor do rótulo que é exibido na interface do usuário.
    • Se o erro indicar Campo Cliente não encontrado..., substitua o cabeçalho da coluna 'Cliente' por 'Fornecedor'
  2. Salve suas modificações.
  3. Crie um novo arquivo ZIP de importação legado.
  4. Tente importar novamente.

Informações adicionais:

(Voltar à lista)

8

Ignorando MONEY FIELD devido à exceção ParseException: não é possível localizar moeda com prefixo=$ e sufixo=null

Causa:

  • Você incluiu símbolos de moeda (como $, € ou ¥) nas entradas para campos de dinheiro.

Solução:

  1. Abra o arquivo CSV e remova quaisquer símbolos de moeda.
  2. Salve suas modificações.
  3. Crie um novo arquivo ZIP de importação legado.
  4. Tente importar novamente.

Informações adicionais:

  • Para inserir uma moeda específica em um campo monetário, você deve inserir o valor com o formato 'MONEY VALUE CURRENCY ABBREVIATION. As seguintes entradas de lista demonstram este formato:
    • '50 USD
    • '1000 EUR
    • '80000 JPY
  • Importar contratos anteriores: erro de moeda

(Voltar à lista)

9

Erro ao salvar o conteúdo do arquivo para o documento ContractDocuments.csv: java.io.FileNotFoundException

Causa:

  • O nome do documento mencionado no erro não corresponde ao nome de nenhuma das entradas na coluna Arquivo do arquivo ContractDocuments.csv.

Solução:

  1. Abra o arquivo ContractDocuments.csv.
  2. Certifique-se de que todas as entradas na coluna Arquivo correspondem aos nomes dos documentos que você está tentando importar.
  3. Salve suas modificações.
  4. Crie um novo arquivo ZIP de importação legado.
  5. Tente importar novamente.

Informações adicionais:

(Voltar à lista)

10Exceção ao compactar diretório...

Causa:

  • Você incluiu caracteres especiais em qualquer um dos seguintes locais:
    • O nome de um documento que você está importando.
    • Uma entrada na coluna Arquivo do arquivo ContractDocuments.csv.

Solução:

  1. Remova caracteres especiais de qualquer um dos arquivos que você gostaria de importar.
  2. Abra o arquivo ContractDocuments.csv.
  3. Atualize quaisquer entradas na coluna Arquivo afetadas pela alteração dos nomes dos arquivos.
  4. Salve suas modificações.
  5. Crie um novo arquivo ZIP de importação legado.
  6. Tente importar novamente.

Informações adicionais:

(Voltar à lista)

11Erro ao analisar "username@domain.com": o número de chaves de pesquisa não corresponde ao número de valores fornecidos.

Causa:

  • Um dos valores de pesquisa necessários para localizar o valor do campo no site está ausente.
  • Por exemplo, você deve adicionar entradas no campo Usuário com o seguinte formato: [passwordAdapter]:[username]. Se o valor [passwordAdapter] estiver ausente, você encontrará esse erro.

Solução:

  1. Abra o arquivo CSV e localize a entrada mencionada no erro.
  2. Corrija o formato da entrada para que ela inclua os valores necessários.
  3. Salve suas modificações.
  4. Crie um novo arquivo ZIP de importação legado.
  5. Tente importar novamente.

Informações adicionais

(Voltar à lista)



Aplicável a

Contratos estratégicos > Contratos estratégicos - importação/exportação

Termos de uso  |  Copyright  |  Divulgação de segurança  |  Privacidade