Domande frequenti KB0405759
Posta elettronica
Quali sono gli errori più comuni riscontrati durante l'importazione dei contratti precedenti?
Per comodità dell'utente, questo articolo della Knowledge Base è stato tradotto automaticamente. SAP non fornisce alcuna garanzia in merito alla correttezza o alla completezza della traduzione automatica. È possibile visualizzare il contenuto originale passando all'inglese nel selettore della lingua.
Sintomo

Quali sono gli errori più comuni riscontrati durante l'importazione dei contratti precedenti?

Come risolvere gli errori comuni di importazione dei contratti precedenti?


Soluzione

Il seguente elenco include gli errori più comuni riscontrati durante l'importazione di contratti precedenti. Selezionare il testo dell'errore per passare alla relativa riga nella tabella:

  1. FileNotFoundException: nome file (file o directory non presente)
  2. Non si dispone di un modello pubblicato con nome...
  3. Nome modello non applicabile
  4. next() ha rilevato un errore di analisi AQL: istruzione di elaborazione letterale di stringa non valida...
  5. NoSuchElementException: null
  6. Errore utente '' non trovato (o) utente 'null' non trovato (o) delle istanze ContractId con ='[BaseId]', uno ha DocumentId [BaseId], mentre un altro ha (argomento mancante)
  7. Campo fieldName non trovato...
  8. MONEY FIELD ignorato a causa dell'eccezione ParseException: impossibile trovare la valuta con prefisso=$ e suffisso=null
  9. Errore durante il salvataggio del contenuto del file per il documento ContractDocuments.csv: java.io.FileNotFoundException
  10. Eccezione durante la compressione della directory...
  11. Errore di analisi "username@domain.com": il numero di chiavi di ricerca non corrisponde al numero di valori indicato.

La seguente tabella

N. SLErrore Causa e soluzione
1FileNotFoundException: nome file (file o directory non presente)

Causa:

  • L'archivio ZIP di importazione precedente è stato creato da una cartella anziché dai singoli documenti.
    • È necessario creare il file di archivio direttamente dai file CSV ed eventuali documenti supplementari che si intende caricare. Se si aggiungono i CSV e altri documenti a una cartella, creare l'archivio ZIP dalla cartella, il processo di importazione non riuscirà.
  • I nomi dei file menzionati in ImportProjectParameters.csv non sono corretti; i nomi devono essere conformi al nome o al formato CSV standard e fanno distinzione tra maiuscole e minuscole.
  • Mancano uno o più dei 4 file CSV.
    • Ogni file ZIP di importazione precedente deve contenere tutti i file CSV richiesti.
    • È comunque necessario includere ContractDocuments.csv e ContractTeams.csv anche se i file sono vuoti.
  • File ImportProjectParameters.csv mancante.

Soluzione:

  1. Correggere gli errori nell'archivio ZIP o nei relativi file.
  2. Riprovare l'importazione.

(Torna all'elenco)

2Non si dispone di un modello pubblicato con nome ...

Causa:

  • Questo errore si verifica quando il modello menzionato in ImportProjectParameters.csv è Inattivo o non pubblicato (stato Bozza).

Soluzione:

  1. Riattivare e pubblicare il modello.
  2. Riprovare l'importazione.

Informazioni supplementari

(Torna all'elenco)

3Nome modello non applicabile

Causa:

  • Il modello menzionato ha una condizione di visibilità impostata su di esso, pertanto non può essere utilizzato.

Soluzione:

  1. Creare una nuova versione del modello.
  2. Rimuovi la condizione di visibilità
  3. Pubblicare la nuova versione del modello.
  4. Riprovare l'importazione.

Informazioni supplementari:

  • Si consiglia di creare un modello vuoto separato che può essere utilizzato solo per importare contratti precedenti.

(Torna all'elenco)

4next() ha rilevato un errore di analisi AQL: istruzione di elaborazione letterale di stringa non valida...

Causa:

  • Il file di importazione CSV contiene un'interruzione di riga in uno dei valori delle colonne indicati.

Soluzione

    1. Aprire il file CSV in un editor di testo semplice.
    2. Individuare i valori della colonna menzionata nell'errore e rimuovere l'interruzione di riga o lo spazio
    3. Salvare le modifiche.
    4. Creare un nuovo archivio ZIP di importazione legacy.
    5. Riprovare l'importazione.

Informazioni supplementari:

(Torna all'elenco)

5NoSuchElementException: null

Causa:

  1. Il testo in uno dei campi del file di importazione CSV contiene virgolette doppie ("), molto probabilmente vicino alla fine della voce.

Soluzione:

  1. Aprire il file CSV in un editor di testo semplice.
  2. Individuare gli inserimenti per l'ultima riga importata correttamente.
  3. Nella riga successiva (la riga che corrisponde all'errore), verificare la presenza di virgolette doppie negli inserimenti (").
  4. Rimuovere le virgolette doppie.
  5. Salvare le modifiche.
  6. Creare un nuovo archivio ZIP di importazione legacy.
  7. Riprovare l'importazione.

Informazioni supplementari

(Torna all'elenco)

6Errore Errore utente '' non trovato o

Utente "null" non trovato o

Di istanze ContractId con ='[BaseId]', uno ha DocumentId [BaseId], mentre un altro ha (argomento mancante)

Causa:

  • È stato riutilizzato uno dei file CSV di un'importazione preesistente precedente, ma sono state immesse meno righe di dati.

Soluzione:

  1. Aprire il file CSV in un editor di testo semplice.
  2. Andare alla fine del file e verificare la presenza di righe contenenti solo virgole (,).
  3. Se presenti, eliminare queste righe.
  4. Salvare le modifiche.
  5. Creare un nuovo archivio ZIP di importazione legacy.
  6. Riprovare l'importazione.

Informazioni supplementari:

(Torna all'elenco)

7Campo FieldName non trovato...

Causa:

  • Il nome univoco di uno dei campi utilizzati come intestazione colonna non è corretto. Inizia con cus_FieldName.
  • Se l'errore indica che "Cliente" non esiste, questo valore di intestazione deve essere Fornitore.

Soluzione:

  1. Aprire ogni file CSV e rivedere i valori dell'intestazione della colonna.
    • Tutti i campi personalizzati devono utilizzare il valore del nome del campo (in genere formattato come cus_FieldName), non il valore dell'etichetta visualizzato nell'interfaccia utente.
    • Se l'errore indica Campo Cliente non trovato... , sostituire l'intestazione della colonna 'Cliente' con 'Fornitore'
  2. Salvare le modifiche.
  3. Creare un nuovo archivio ZIP di importazione legacy.
  4. Riprovare l'importazione.

Informazioni supplementari:

(Torna all'elenco)

8

MONEY FIELD ignorato a causa dell'eccezione ParseException: impossibile trovare la valuta con prefisso=$ e suffisso=null

Causa:

  • Sono stati inclusi simboli di valuta (ad esempio $, € o ¥) negli inserimenti per i campi monetari.

Soluzione:

  1. Aprire il file CSV e rimuovere eventuali simboli di valuta.
  2. Salvare le modifiche.
  3. Creare un nuovo archivio ZIP di importazione legacy.
  4. Riprovare l'importazione.

Informazioni supplementari:

  • Per inserire una divisa specifica in un campo monetario, è necessario inserire il valore con il formato 'MONEY VALUE CURRENCY ABBREVIATION. Le seguenti voci dell'elenco dimostrano questo formato:
    • «50 USD
    • «1000 EUR
    • «80000 JPY
  • Importazione contratti precedenti: errore valuta

(Torna all'elenco)

9

Errore durante il salvataggio del contenuto del file per il documento ContractDocuments.csv: java.io.FileNotFoundException

Causa:

  • Il nome del documento menzionato nell'errore non corrisponde al nome di nessuna delle voci nella colonna File del file ContractDocuments.csv.

Soluzione:

  1. Aprire il file ContractDocuments.csv.
  2. Assicurarsi che tutti gli inserimenti nella colonna File corrispondano ai nomi dei documenti che si sta tentando di importare.
  3. Salvare le modifiche.
  4. Creare un nuovo archivio ZIP di importazione legacy.
  5. Riprovare l'importazione.

Informazioni supplementari:

(Torna all'elenco)

10Eccezione durante la compressione della directory...

Causa:

  • Sono stati inclusi caratteri speciali in uno dei seguenti punti:
    • Il nome di un documento che si sta importando.
    • Una voce nella colonna File del file ContractDocuments.csv.

Soluzione:

  1. Rimuovere i caratteri speciali da uno qualsiasi dei file che si desidera importare.
  2. Aprire il file ContractDocuments.csv.
  3. Aggiornare eventuali inserimenti nella colonna File interessati dalla modifica dei nomi dei file.
  4. Salvare le modifiche.
  5. Creare un nuovo archivio ZIP di importazione legacy.
  6. Riprovare l'importazione.

Informazioni supplementari:

(Torna all'elenco)

11Errore di analisi "username@domain.com": il numero di chiavi di ricerca non corrisponde al numero di valori indicato.

Causa:

  • Uno dei valori di ricerca richiesti per individuare il valore del campo nel sito è mancante.
  • Ad esempio, è necessario aggiungere inserimenti nel campo Utente con il seguente formato: [passwordadapter]:[username]. Se il valore [passwordadapter] è mancante, si verificherà questo errore.

Soluzione:

  1. Aprire il file CSV e individuare la voce menzionata nell'errore.
  2. Correggere il formato dell'inserimento in modo che includa i valori necessari.
  3. Salvare le modifiche.
  4. Creare un nuovo archivio ZIP di importazione legacy.
  5. Riprovare l'importazione.

Informazioni supplementari

(Torna all'elenco)



Si applica a

Contratti strategici > Importazione/esportazione contratti strategici

Condizioni di utilizzo  |  Copyright  |  Informazioni sulla sicurezza  |  Privacy