Preguntas más frecuentes KB0405759
Correo electrónico
¿Cuáles son los errores más comunes encontrados durante la importación de contratos heredados?
Este artículo de la base de conocimientos ha sido traducido automáticamente para su comodidad. SAP no ofrece ninguna garantía con respecto a la exactitud o integridad de la traducción automática. Puede acceder al contenido original si cambia al inglés mediante el selector de idiomas.
Síntoma

¿Cuáles son los errores más comunes encontrados durante la importación de contratos heredados?

¿Cómo resuelvo los errores comunes de importación de contratos heredados?


Resolución

La siguiente lista incluye los errores más comunes encontrados al importar contratos heredados. Seleccione el texto del error para saltar a su fila en la tabla:

  1. FileNotFoundException: filename (no existe tal archivo o directorio)
  2. No tiene una plantilla publicada con el nombre...
  3. El nombre de la plantilla no es aplicable
  4. next() ha encontrado un error de análisis AQL: instrucción de procesamiento literal de cadena mal formada...
  5. NoSuchElementException: nulo
  6. El usuario '' no ha encontrado el error (o) El usuario 'null' no se ha encontrado (o) de instancias de ContractId con ='[BaseId]', una tiene DocumentId [BaseId], pero otra tiene (falta el argumento)
  7. El campo fieldName no existe...
  8. Omitiendo MONEY FIELD debido a la excepción ParseException: No se puede encontrar la moneda con prefijo=$ y sufijo=null
  9. Error al guardar el contenido del archivo para el documento ContractDocuments.csv: java.io.FileNotFoundException
  10. Excepción al comprimir el directorio...
  11. Error al analizar "username@domain.com": El número de claves de búsqueda no coincide con el número de valores indicados.

La siguiente tabla

NºLinealError Causa y solución
1FileNotFoundException: filename (no existe tal archivo o directorio)

Causa:

  • El archivo ZIP de importación heredado se creó a partir de una carpeta en lugar de los documentos individuales.
    • Debe crear el fichero de archivo directamente desde los ficheros CSV y cualquier documento adicional que tenga previsto cargar. Si añade los CSV y otros documentos a una carpeta, cree el archivo ZIP desde la carpeta y el proceso de importación fallará.
  • Los nombres de archivo mencionados en ImportProjectParameters.csv son incorrectos - los nombres deben ser según el nombre o formato de archivo CSV estándar y distinguen entre mayúsculas y minúsculas.
  • Faltan uno o más de los 4 archivos CSV.
    • Cada archivo ZIP de importación heredado debe contener todos los archivos CSV necesarios.
    • Aún debe incluir ContractDocuments.csv y ContractTeams.csv aunque los archivos estén vacíos.
  • Falta el archivo ImportProjectParameters.csv.

Solución:

  1. Corrija los errores en el archivo ZIP o sus ficheros.
  2. Vuelva a intentar la importación.

(Volver a la lista)

2No tiene una plantilla publicada con el nombre ...

Causa:

  • Este error se produce cuando la plantilla mencionada en ImportProjectParameters.csv está Inactiva o no publicada (estado Borrador).

Solución:

  1. Reactive y publique la plantilla.
  2. Vuelva a intentar la importación.

Información adicional

(Volver a la lista)

3El nombre de la plantilla no es aplicable

Causa:

  • La plantilla mencionada tiene una condición de visibilidad fijada, por lo que no se puede utilizar.

Solución:

  1. Cree una nueva versión de la plantilla.
  2. Eliminar la condición de visibilidad
  3. Publique la nueva versión de plantilla.
  4. Vuelva a intentar la importación.

Información adicional:

  • Recomendamos crear una plantilla vacía separada que se pueda utilizar solo para importar contratos heredados.

(Volver a la lista)

4next() ha encontrado un error de análisis AQL: instrucción de procesamiento literal de cadena mal formada...

Causa:

  • El archivo de importación CSV contiene un salto de línea en uno de los valores de columna indicados.

Solución

    1. Abra el archivo CSV en un editor de texto simple.
    2. Localice los valores de la columna mencionada en el error y elimine el salto de línea o el espacio
    3. Guarde las modificaciones.
    4. Cree un nuevo archivo ZIP de importación heredado.
    5. Vuelva a intentar la importación.

Información adicional:

(Volver a la lista)

5NoSuchElementException: nulo

Causa:

  1. El texto de uno de los campos del archivo de importación CSV contiene comillas dobles ("), probablemente cerca del final de la entrada.

Solución:

  1. Abra el archivo CSV en un editor de texto simple.
  2. Localice las entradas de la última fila importada correctamente.
  3. En la siguiente fila (la fila que corresponde al error), verifique las entradas con comillas dobles (").
  4. Elimine las comillas dobles.
  5. Guarde las modificaciones.
  6. Cree un nuevo archivo ZIP de importación heredado.
  7. Vuelva a intentar la importación.

Información adicional

(Volver a la lista)

6El usuario '' no ha encontrado el error o

El usuario 'null' no se ha encontrado o

De instancias ContractId con ='[BaseId]', una tiene DocumentId [BaseId], pero otra tiene (falta argumento)

Causa:

  • Ha reutilizado uno de los archivos CSV de una importación heredada anterior, pero ha introducido menos filas de datos.

Solución:

  1. Abra el archivo CSV en un editor de texto simple.
  2. Vaya al final del archivo y compruebe si hay filas que solo contengan comas (,).
  3. Si existen, elimine estas filas.
  4. Guarde las modificaciones.
  5. Cree un nuevo archivo ZIP de importación heredado.
  6. Vuelva a intentar la importación.

Información adicional:

(Volver a la lista)

7No se ha encontrado el campo FieldName...

Causa:

  • El nombre unívoco de uno de los campos utilizados como cabecera de columna es incorrecto. Empieza por cus_FieldName.
  • Si el error indica que "Cliente" no existe, este valor de cabecera debe ser Proveedor.

Solución:

  1. Abra cada archivo CSV y revise los valores de cabecera de columna.
    • Cualquier campo personalizado debe utilizar el valor del nombre de campo (normalmente formateado como cus_FieldName), no el valor de etiqueta que se muestra en la interfaz de usuario.
    • Si el error indica Campo Cliente no encontrado..., sustituya la cabecera de columna "Cliente" por "Proveedor"
  2. Guarde las modificaciones.
  3. Cree un nuevo archivo ZIP de importación heredado.
  4. Vuelva a intentar la importación.

Información adicional:

(Volver a la lista)

8

Omitiendo MONEY FIELD debido a la excepción ParseException: No se puede encontrar la moneda con prefijo=$ y sufijo=null

Causa:

  • Ha incluido símbolos de moneda (como $, € o ¥) en las entradas para los campos de dinero.

Solución:

  1. Abra el archivo CSV y elimine cualquier símbolo de moneda.
  2. Guarde las modificaciones.
  3. Cree un nuevo archivo ZIP de importación heredado.
  4. Vuelva a intentar la importación.

Información adicional:

  • Para introducir una moneda específica en un campo de dinero, debe introducir el valor con el formato 'MONEY VALUE CURRENCY ABBREVIATION. A continuación se enumeran las entradas que demuestran este formato:
    • «50 USD
    • «1000 EUR
    • «80000 JPY
  • Importar contratos heredados: Error de moneda

(Volver a la lista)

9

Error al guardar el contenido del archivo para el documento ContractDocuments.csv: java.io.FileNotFoundException

Causa:

  • El nombre del documento mencionado en el error no coincide con el nombre de ninguna de las entradas de la columna Archivo del archivo ContractDocuments.csv.

Solución:

  1. Abra el archivo ContractDocuments.csv.
  2. Asegúrese de que todas las entradas de la columna Archivo coincidan con los nombres de los documentos que está intentando importar.
  3. Guarde las modificaciones.
  4. Cree un nuevo archivo ZIP de importación heredado.
  5. Vuelva a intentar la importación.

Información adicional:

(Volver a la lista)

10Excepción al comprimir el directorio...

Causa:

  • Ha incluido caracteres especiales en cualquiera de los siguientes lugares:
    • El nombre de un documento que está importando.
    • Una entrada en la columna Archivo del archivo ContractDocuments.csv.

Solución:

  1. Elimine los caracteres especiales de cualquiera de los archivos que desee importar.
  2. Abra el archivo ContractDocuments.csv.
  3. Actualice las entradas en la columna Archivo afectadas por el cambio de los nombres de archivo.
  4. Guarde las modificaciones.
  5. Cree un nuevo archivo ZIP de importación heredado.
  6. Vuelva a intentar la importación.

Información adicional:

(Volver a la lista)

11Error al analizar "username@domain.com": El número de claves de búsqueda no coincide con el número de valores indicados.

Causa:

  • Falta uno de los valores de consulta necesarios para localizar el valor del campo en el sitio.
  • Por ejemplo, debe agregar entradas en el campo Usuario con el siguiente formato: [passwordapter]:[username]. Si falta el valor [passwordapter], se producirá este error.

Solución:

  1. Abra el archivo CSV y localice la entrada mencionada en el error.
  2. Corrija el formato de la entrada para que incluya los valores necesarios.
  3. Guarde las modificaciones.
  4. Cree un nuevo archivo ZIP de importación heredado.
  5. Vuelva a intentar la importación.

Información adicional

(Volver a la lista)



Se aplica a

Contratos estratégicos > Contratos estratégicos - Importar/Exportar

Condiciones de uso  |  Copyright  |  Declaración de seguridad  |  Privacidad