FAQ KB0405373
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How do I activate/deactivate or add an extra supplier contact in Ariba SLP through CSV import?
Symptom

Supplier is inactive. Supplier is active.


Cause

Contacts needs to be edited via .csv import file


Resolution

To de-activate or reactivate a contact to an existing supplier, please follow the steps below:

  1. Click Manage > SM Administration > Data Import and Export.
  2. The File type must be set to Supplier Contacts.
  3. After that, click the Export link.

A file named ContactsExport.csv will be downloaded in your computer. Open the file in notepad++ or in another pure text editor (Excel is not recommended for this purpose) and proceed with the following steps:

  1. Copy the 1st line (header) to a new file, and save as a new .csv somewhere in your computer.
  2. Go back to the previous ContactsExport.csv file. You will have one line for every supplier contact from your realm.
  3. Locate the contact you want to activate/deactivate and copy the whole line
  4. Paste the entire line below the header in the new .csv file
  5. Change the current value in the active column
  6. Optional: Repeat the steps 2 to 4 for all the supplier contacts you need to de-activate

After these steps, the .csv file will look like this:

erpVendorId,supplierName,sourceSystem,firstName,middleName,lastName,countryCode,telephone,mobileCountryCode,mobilePhone,email,type,locale,title,categories,regions,active,timeZoneID,isPrimary,department
VDR472419,Supplier Training II,SM,Someone,,From Support,,,,,noreply@sap.com,,,,,,false,US/Pacific,true,

We now need to import the .csv file back to Ariba:

  1. Click Manage > SM Administration > Data Import and Export.
  2. The File type must be set to Supplier Contact.
  3. Click Load and locate the file in your computer
  4. Click the Import link
  5. Follow up the process clicking in the Import Summary tab

When the process ends, Ariba will de-activate or activate the supplier contact and other required tasks in the backend.


See Also

To create a new contact to an existing supplier, please follow the steps below:

  1. Click Manage > SM Administration > Data Import and Export.
  2. The File type must be set to Supplier Contacts.
  3. After that, click the Export link.

A file named ContactsExport.csv will be downloaded in your computer. Open the file in notepad++ or in another pure text editor (Excel is not recommended for this purpose) and proceed with the following steps:

  1. Copy the 1st line (header) to a new file, and save as New-Contact.csv somewhere in your computer.
  2. Go back to the previous ContactsExport.csv file. You will have one line for every supplier contact from your realm. Copy the whole line from one contact to use as example.
  3. Paste the entire line below the header in the New-Contact.csv file
  4. Make sure the value from the active flag is true
  5. Ensure there is no blank line/spaces at the end of file as it might not update the data.
  6. Optional: Repeat the steps 2 to 4 for if you want to add multiple contacts.

After these steps, the New-Contact.csv file will look like this:

erpVendorId,supplierName,sourceSystem,firstName,middleName,lastName,countryCode,telephone,mobileCountryCode,mobilePhone,email,type,locale,title,categories,regions,active,timeZoneID,isPrimary,department
VDRxxxx,Supplier Training II,SM,Someone,,From Support,,,,,noreply@sap.com,,,,,,true,US/Pacific,true,

  1. Click Manage > SM Administration > Data Import and Export.
  2. The File type must be set to Supplier Contact.
  3. Click Load and locate New-Contact.csv file in your computer
  4. Click the Import link
  5. Follow up the process clicking in the Import Summary tab

When the process ends, check again the Contacts tab in the SLP supplier profile.



Applies To

Supplier Lifecycle & Performance > Contacts

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