Support-Hinweis KB0404946
E-Mail
Fehler in verwaltetem Gateway für Spend Management und SAP Business Network: "CIG-PLT-04641: Die eingehende Nachricht ist mit den folgenden Fehlern ungültig: urn:Ariba:Buyer:vsap:PurchaseOrderAsyncImportPull@ line 31 in SoapResponseParse.groovy"
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Symptom

PurchaseOrderAsyncImportPull-Transaktionen schlagen in "SAP Integration Suite, verwaltetes Gateway für Spend Management" und im Transaktions-Tracker von SAP Business Network mit dem folgenden Fehler fehl:

Fehler: Dokument während HTTP/SOAP-Post für Kunde <Käufer-ANID> fehlgeschlagen - Bereichsname <Bereichs-ID> und empfangene SOAP-Fault-Nachricht: java.lang.Exception: java.lang.Exception: SOAP Fault :Die eingehende Nachricht ist mit den folgenden Fehlern ungültig: urn:Ariba:Buyer:vsap:PurchaseOrderAsyncImportPull@ Zeile 31 in SoapResponseParse.groovy. Vorgeschlagene Aktion: Wenden Sie sich mit dem Fehlercode CIG-PLT-04641 an den Support für das verwaltete Gateway für Spend Management und SAP Business Network, um weitere Unterstützung zu erhalten.


Ursache

Der ERPPONumber-Wert fehlt in der Ausgangs-Payload im verwalteten Gateway für Spend Management und SAP Business Network für PurchaseOrderAsyncImportPull-Dokumente.


Lösung

Die Korrektur für dieses Problem variiert von Ihrer Version des verwalteten Gateways für Spend Management und SAP Business Network.

Wenn Sie das verwaltete Gateway für Spend Management und SAP Business Network SP6, SP7 oder SP8 verwenden, führen Sie den folgenden Schritt aus, um das Problem zu beheben:

Wenn Sie ein Service Pack (SP) für das verwaltete Gateway für Spend Management und SAP Business Network verwenden, das niedriger als SP6 ist, z.B. SP5, SP4, SP3, SP2 Die Behelfslösung besteht darin, die ursprüngliche Bestellantwort mit der richtigen SAPDocumentID aus Ihrem SAP-ERP-System erneut zu verarbeiten, indem Sie die folgenden Schritte ausführen:

  1. Navigieren Sie in Ihrem SAP-ERP-System zur Transaktion SRT_MONI.
  2. Geben Sie auf dem Selektionsbild in den Feldern "Zeitstempel von", "Zeitstempel bis", "Senderinformationen" > "Schnittstellenname" den Wert ERPToAribaBuyerResponse_Async_Out und die Verarbeitungsstatusgruppe "Systemfehler" ein.
  3. Klicken Sie auf Ausführen.
  4. Wählen Sie alle Datensätze mit Systemfehler aus, und klicken Sie auf Aktionen > Neu starten.
  5. Sie müssen sicherstellen, dass der Benutzer, der zur erneuten Verarbeitung verwendet wird, über die erforderlichen Berechtigungen verfügt.
  6. Wenn dem Benutzer Berechtigungen fehlen, erhalten Sie möglicherweise einen Sequenzfehler bei der erneuten Verarbeitung von SRT_MONI. Wenden Sie sich an Ihr internes SAP-ERP-Basisteam, wenn bei der erneuten Verarbeitung solche Fehler auftreten. Wenn Ihre Basis auch nicht helfen kann, legen Sie eine SAP-OSS-Meldung unter der Komponente BC-ESI-WS-ABA-MO an, um den Sequenzfehler zu beheben. Anweisungen zum Anlegen von OSS-Meldungen finden Sie unter Wie lege ich eine SAP-OSS-Meldung an?

Siehe auch

Sie können die tatsächliche SOAP-Fehlerantwort, die von der SAP-Ariba-Operational-Procurement-Lösung für dieses Dokument gesendet wurde, aus dem Transaktions-Tracker des verwalteten Gateway für Spend Management und SAP Business Network herunterladen, indem Sie die folgenden Schritte ausführen:

  1. Klicken Sie auf das rote Symbol ( ) für die Transaktionsnummer mit dem Status FEHLGESCHLAGEN im verwalteten Gateway für Spend Management und SAP Business Network TT.
  2. Ein Bild wird angezeigt, auf dem Sie die eigentliche Fehlermeldung herunterladen können.
  3. Klicken Sie auf Herunterladen.
  4. Der Text der SOAP-Antwort der Lösung SAP Ariba Operational Procurement in dieser Fehler-XML, die Sie heruntergeladen haben, sieht wie folgt aus:

    <soapenv:Body>

    <soapenv:Fault>

    <Faultcode>Interner Serverfehler</Faultcode>

    <Faultstring>Die eingehende Nachricht ist mit folgenden Fehlern ungültig: urn:Ariba:Buyer:vsap:PurchaseOrderAsyncImportPull</Faultstring>

    <Detail>cvc-komplex-type.2.4.b: Der Inhalt des Elements 'urn:item' ist nicht vollständig. Eine der folgenden: "{"urn:Ariba:Buyer:vsap":ERPPONumber, "urn:Ariba:Buyer:vsap":NumberInCollection, "urn:Ariba:Buyer:vsap":PODeliveryDate, "urn:Ariba:Buyer:vsap":POQuantity, "urn:Ariba:Buyer:vsap":PackageInfo, "urn:Ariba:Buyer:vsap":Mapn:Mapn}</Detail>

    </soapenv:Fault>

    </soapenv:Body>

Als Nächstes können Sie die folgende Logik anwenden, um den oben genannten SOAP-Fehler zu interpretieren:



Gilt für

SAP Integration Suite, verwaltetes Gateway > Verwaltetes Gateway für Bestellabwicklung

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