Nota di supporto KB0404713
Posta elettronica
Ordine d'acquisto non riuscito con errore "PO-11: impossibile consegnare l'ordine. (...) Traduzione non riuscita". Come si utilizza il rapporto di traduzione EDI per gli ordini d'acquisto non riusciti?
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Sintomo

L'ordine d'acquisto ha raggiunto SAP Business Network, ma non è riuscito a raggiungere il sistema integrato del fornitore (tramite EDI) con il seguente messaggio di errore:

PO-11: Impossibile consegnare l'ordine. Codice errore terminale per stato OdA: traduzione non riuscita per XXXX

Come si utilizza il rapporto di traduzione per un ordine d'acquisto non riuscito per comprendere la causa dell'errore e risolverlo?


Causa

Il messaggio di errore Traduzione non riuscita verrà visualizzato in diversi scenari di errore di integrazione EDI.

Se viene visualizzato per un documento di ordine d'acquisto, significa che non è stato possibile tradurre il documento cXML dell'ordine in EDI a causa della causa indicata nel rapporto di traduzione. Può trattarsi di un campo errato o di dati di blocco o di un loro utilizzo errato. Un altro motivo di errore comune sono gli ordini d'acquisto con caratteri non validi, non supportati da EDI.

Il report di traduzione è uno strumento molto utile per identificare la causa dell'errore di integrazione


Soluzione

Per visualizzare il report di traduzione, attenersi alla seguente procedura:

  1. Accesso a SAP Business Network.
  2. Individuare l'ordine d'acquisto non riuscito con l'errore Traduzione non riuscita.
  3. Fare clic su Cronologia ordine.

Il report di traduzione viene visualizzato nella colonna Commenti per lo stato Non riuscito. Solitamente non avrà interruzioni di riga, ma avrà l'aspetto dell'esempio seguente:

Traduzione non riuscita per XXXXXXXXX :
Report di traduzione
------------------
Formato dati errato (110)
Conteggio blocchi = 13
NomeBlocco = ItemOut
BlockSignatureIdTag = LINE
FieldName = ItemID_SupplierPartID
FieldNumber = 3
FieldData = 152A77.
Formato dati errato (110)
Conteggio blocchi = 15
BlockName = 2010_PO1_ItemOut
BlockSignatureIdTag = PO1
FieldName = 0234_ItemID_SuppPartID_data
FieldNumber = 7
FieldData = 152A77.

La prima riga dopo il titolo e il delimitatore del report (------------------) informerà il problema, in questo caso specifico, del formato dati errato. Il campo e il blocco vengono visualizzati subito dopo: il blocco di informazioni è ItemOut e il campo con dati errati o non validi è SupplierPartID.

Nell'esempio precedente è chiaro che esiste un carattere non valido nei dati (righe FieldData). Tuttavia, ciò non viene sempre mostrato così chiaramente nella relazione di traduzione. Se viene visualizzato un errore Formato dati errato ma non è possibile individuare il carattere errato nella riga FieldData, è possibile scaricare il cXML dell'ordine d'acquisto da SAP Business Network e visualizzarlo in un editor con il supporto di caratteri non ANSI, ad esempio Microsoft Notepad o Notepad++.

Una risorsa utile da utilizzare insieme al rapporto di traduzione è la ANSI X12 Resource: 850 Purchase Order Implementation Guide, disponibile nella sezione Integrazione della pagina SAP Business Network per partner commerciali nel SAP Help Portal.

Tenere presente anche che i report di traduzione possono visualizzare più problemi contemporaneamente. L'esempio riportato sopra segnala due occorrenze dello stesso problema di formato dati errato, per due campi diversi.

Possiamo vedere anche altri errori nei rapporti di traduzione. Vedere di seguito un esempio di errore Dati obbligatori mancanti:

Traduzione non riuscita per XXXXXXXXX :
Report di traduzione
------------------
Dati obbligatori mancanti (100)
Conteggio blocchi = 32
BlockName = estrinseco
BlockSignatureIdTag = HDEXNA
FieldName = Nome_estrinseco
FieldNumber = 1

In questo esempio, nell'ordine d'acquisto è stato inviato un elemento estrinseco senza nome. Se si estrae il cXML per questo ordine d'acquisto, viene visualizzato lo snippet riportato di seguito, che ha causato questo errore:

<Nome estrinseco=""/>

Infine, i report di traduzione possono anche mostrare direttamente gli errori, anche prima del report stesso. L'esempio seguente è un errore molto comune nell'integrazione EDI per gli ordini d'acquisto:

Traduzione non riuscita per 428967976 :
Registro traduzione (1 inserimenti):
----------------------------
ERRORE: /cXML/Request/OrderRequest; isAdhoc e SupplierPartId sono entrambi mancanti. Includerne almeno uno.
Report di traduzione
------------------
Dati obbligatori mancanti (100)
GroupName = ItemOut_cxml
Istanza = 00
ID campo = 3
FieldData = null
Codice di utilizzo regola standard
Dati mancanti (142)
Conteggio blocchi = 57
NomeBlocco = 2180_FOB
BlockSignatureIdTag = FOB
Nome campo = 0335
FieldNumber = 5
Dati campo = ZZZ

La riga ERRORE in questo caso spiega già la causa del problema, senza dover passare oltre i dettagli del blocco EDI. Fare riferimento all'ordine d'acquisto non riuscito con l'errore "Traduzione non riuscita (...) isAdhoc e SupplierPartId entrambi mancanti" per istruzioni specifiche su questo scenario.


Vedi anche

Consultare la sezione Integrazione della pagina SAP Business Network per partner commerciali nel SAP Help Portal per tutte le guide all'implementazione e alla configurazione e ulteriori risorse sull'integrazione EDI con SAP Business Network.



Si applica a

Approvvigionamento di base > Amministrazione centrale > Integrazione applicazione (tra Buying e Sourcing)

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