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Le BdC échoue avec l'erreur "BdC-11 : impossible de livrer la commande. (...) Échec de la traduction". Comment utiliser le rapport de traduction EDI pour les bons de commande en échec ?
Cet article de la base de connaissances a été traduit automatiquement pour vous faciliter la tâche. SAP ne garantit pas l'exactitude ou l'exhaustivité de cette traduction automatique. Vous pouvez trouver le contenu d'origine en passant à l'anglais à l'aide du sélecteur de langue.
Symptôme

Le bon de commande a atteint SAP Business Network, mais n'a pas réussi à atteindre le système intégré du fournisseur (via EDI) avec le message d'erreur ci-dessous :

PO-11 : Impossible de livrer la commande. Code d'erreur du terminal pour le statut de la commande d'achat : échec de la traduction pour XXXX

Comment utiliser le rapport de traduction pour un bon de commande en échec afin de comprendre la cause de l'erreur et de la résoudre ?


Cause

Le message d'erreur Échec de la traduction s'affiche dans plusieurs scénarios d'erreur d'intégration EDI.

S'il apparaît pour un document de bon de commande, cela signifie que le document cXML de commande n'a pas pu être traduit en EDI, en raison de la cause décrite dans le rapport de traduction. Il peut s'agir d'une zone ou de données de blocage incorrectes ou d'une utilisation incorrecte de celles-ci. Les bons de commande comportant des caractères non valides, non pris en charge par EDI, constituent un autre motif d'échec courant.

Le programme de traduction est un outil très utile pour identifier la cause de l'erreur d'intégration.


Résolution

Pour afficher le rapport de traduction, suivez les étapes ci-dessous :

  1. Connectez-vous à SAP Business Network.
  2. Localisez le bon de commande qui a échoué avec l'erreur Échec de la traduction.
  3. Cliquez sur Historique de la commande.

Le rapport de traduction est affiché dans la colonne Commentaires pour le statut Échec. Il n'y aura généralement pas de sauts de ligne, mais ressemblera à l'exemple ci-dessous :

Échec de la traduction pour XXXXXXXXX :
Rapport de traduction
------------------
Format de données incorrect (110)
Nombre de blocs = 13
NomBloc = ItemOut
BlockSignatureIdTag = LIGNE
FieldName = ItemID_SupplierPartID
FieldNumber = 3
FieldData = 152A77Θ
Format de données incorrect (110)
Nombre de blocs = 15
NomBloc = 2010_PO1_ItemOut
BlockSignatureIdTag = PO1
FieldName = 0234_ItemID_SuppPartID_data
FieldNumber = 7
FieldData = 152A77Θ

La première ligne après le titre du rapport et le délimiteur (------------------) indiquera le problème : dans ce cas spécifique, format de données incorrect. La zone et le bloc sont affichés juste après : le bloc d'informations est ItemOut et la zone avec des données incorrectes ou non valides est SupplierPartID.

Dans l'exemple ci-dessus, il est clair qu'il y a un caractère non valide dans les données (lignes FieldData). Ce point n'est cependant pas toujours aussi clair dans le rapport sur la traduction. Si vous voyez une erreur de format de données Incorrect mais que vous ne pouvez pas repérer le caractère incorrect dans la ligne FieldData, vous pouvez télécharger le bon de commande cXML depuis SAP Business Network et l'afficher dans un éditeur prenant en charge les caractères non-ANSI, tels que Microsoft Notepad ou Notepad++.

Une ressource utile à utiliser avec le rapport de traduction est le guide d'implémentation ANSI X12 Resource: 850 Purchase Order, disponible dans la section Intégration de la page SAP Business Network for Trading Partners sur le SAP Help Portal.

Notez également que les rapports de traduction peuvent afficher plusieurs problèmes à la fois. L'exemple ci-dessus signale deux occurrences du même problème de format de données incorrect, pour deux zones différentes.

Nous pouvons également voir d'autres erreurs dans les rapports de traduction. Voir ci-dessous un exemple d'erreur Données obligatoires manquantes :

Échec de la traduction pour XXXXXXXXX :
Rapport de traduction
------------------
Données obligatoires manquantes (100)
Nombre de blocs = 32
NomBloc = Extrinsèque
BlockSignatureIdTag = HDEXNA
FieldName = Extrinsic_name
FieldNumber = 1

Dans cet exemple, un élément extrinsèque sans nom a été envoyé dans le bon de commande. En extrayant le cXML pour ce bon de commande, vous pouvez voir l'extrait de code ci-dessous, qui a provoqué cette erreur :

<Nom extrinsèque=""/>

Enfin, les rapports de traduction peuvent également afficher des erreurs directement, même avant le rapport lui-même. L'exemple ci-dessous est une erreur très courante dans l'intégration EDI pour les bons de commande :

Échec de la traduction pour 428967976 :
Journal de traduction (1 entrée) :
----------------------------
ERREUR : /cXML/Request/OrderRequest ; isAdhoc et SupplierPartId sont tous les deux manquants. Incluez au moins l'un de ces éléments.
Rapport de traduction
------------------
Données obligatoires manquantes (100)
GroupName = ItemOut_cxml
Instance = 00
FieldId = 3
FieldData = nul
Code d'utilisation de règle standard
Données manquantes (142)
Nombre de blocs = 57
NomBloc = 2180_FOB
BlockSignatureIdTag = FAB
FieldName = 0335
FieldNumber = 5
FieldData = ZZZ

La ligne ERREUR dans ce cas explique déjà la cause du problème, sans qu'il soit nécessaire de passer en revue les détails du bloc EDI. Échec de la référence au bon de commande avec l'erreur "Échec de la traduction (...) isAdhoc et SupplierPartId manquants" pour obtenir des instructions spécifiques sur ce scénario.


Voir aussi

Voir la section Intégration de la page SAP Business Network pour les partenaires commerciaux sur le SAP Help Portal pour tous les guides d'implémentation et de configuration, ainsi que des ressources supplémentaires sur l'intégration EDI à SAP Business Network.



S'applique à

Approvisionnement central > Administration centrale > Intégration de l'application (entre Buying et Sourcing)

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