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Die Bestellung schlägt mit dem Fehler "PO-11: Cannot delivery order. (...)" fehl. Übersetzung fehlgeschlagen". Wie verwende ich den EDI-Übersetzungsreport für fehlgeschlagene Bestellungen?
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Symptom

Der Bestellauftrag hat SAP Business Network erreicht, konnte jedoch das integrierte Lieferantensystem (über EDI) mit der folgenden Fehlermeldung nicht erreichen:

PO-11: Bestellung kann nicht geliefert werden. Terminalfehlercode für Bestellstatus: Übersetzung für XXXX fehlgeschlagen

Wie verwende ich den Übersetzungsbericht für einen fehlgeschlagenen Bestellauftrag, um die Fehlerursache zu verstehen und zu beheben?


Ursache

Die Fehlermeldung Übersetzung fehlgeschlagen wird in mehreren EDI-Integrationsfehlerszenarios angezeigt.

Wenn es für ein Bestellauftragsdokument angezeigt wird, bedeutet dies, dass das cXML-Bestellauftragsdokument aufgrund der im Übersetzungsbericht beschriebenen Ursache nicht in EDI übersetzt werden konnte. Es kann sich um falsche Feld- oder Sperrdaten oder um eine falsche Verwendung dieser Daten handeln. Ein weiterer häufiger Fehlergrund sind Bestellaufträge mit ungültigen Zeichen, die von EDI nicht unterstützt werden.

Der Übersetzungsreport ist ein sehr nützliches Werkzeug, um die Ursache des Integrationsfehlers zu identifizieren.


Lösung

Um den Übersetzungsreport anzuzeigen, führen Sie die folgenden Schritte aus:

  1. Melden Sie sich bei SAP Business Network an.
  2. Suchen Sie den Bestellauftrag, der mit dem Fehler Übersetzung fehlgeschlagen fehlgeschlagen ist.
  3. Klicken Sie auf Bestellhistorie.

Der Übersetzungsbericht wird in der Spalte Kommentare für den Status Fehlgeschlagen angezeigt. Sie enthält in der Regel keine Zeilenumbrüche, sondern sieht wie im folgenden Beispiel aus:

Übersetzung für XXXXXXXXX fehlgeschlagen:
Übersetzungsbericht
------------------
Falsches Datenformat (110)
Blockcount = 13
BlockName = ItemOut
BlockSignatureIdTag = LINE
Feldname = ItemID_SupplierPartID
Feldnummer = 3
Felddaten = 152A77
Falsches Datenformat (110)
BlockCount = 15
BlockName = 2010_PO1_ItemOut
BlockSignatureIdTag = PO1
Feldname = 0234_ItemID_SuppPartID_data
Feldnummer = 7
Felddaten = 152A77

Die erste Zeile nach dem Reporttitel und dem Trennzeichen (------------------) informiert über das Problem. In diesem speziellen Fall ist das Datenformat falsch. Das Feld und der Block werden direkt danach angezeigt: Der Informationsblock ist ItemOut, und das Feld mit falschen oder ungültigen Daten ist die SupplierPartID.

Im obigen Beispiel ist klar, dass ein ungültiges Zeichen in den Daten (FieldData-Zeilen) vorhanden ist. Dies wird im Übersetzungsreport jedoch nicht immer so deutlich angezeigt. Wenn der Fehler Falsches Datenformat angezeigt wird, Sie das falsche Zeichen jedoch nicht in der FieldData-Zeile erkennen können, können Sie die Bestellauftrags-cXML aus SAP Business Network herunterladen und in einem Editor mit Unterstützung für Nicht-ANSI-Zeichen wie Microsoft Notepad oder Notepad++ anzeigen.

Eine nützliche Ressource, die Sie zusammen mit dem Übersetzungsbericht verwenden können, ist der ANSI X12 Resource: 850 Purchase Order Implementation Guide, der im Abschnitt Integration der Seite SAP Business Network for Trading Partners im SAP Help Portal verfügbar ist.

Beachten Sie auch, dass Übersetzungsberichte mehrere Probleme gleichzeitig anzeigen können. Das obige Beispiel meldet zwei Vorkommen desselben falschen Datenformatproblems für zwei verschiedene Felder.

Es werden auch andere Fehler in Übersetzungsberichten angezeigt. Im Folgenden finden Sie ein Beispiel für den Fehler Obligatorische Daten fehlen:

Übersetzung für XXXXXXXXX fehlgeschlagen:
Übersetzungsbericht
------------------
Obligatorische Daten fehlen (100)
BlockCount = 32
BlockName = Extrinsisches Element
BlockSignatureIdTag = HDEXNA
Feldname = Extrinsischer_Name
Feldnummer = 1

In diesem Beispiel wurde ein extrinsisches Element ohne Namen im Bestellauftrag gesendet. Beim Abrufen der cXML für diesen Bestellauftrag wird das folgende Snippet angezeigt, das diesen Fehler verursacht hat:

<Name des extrinsischen Elements=""/>

Schließlich können Übersetzungsberichte auch direkt vor dem Report selbst Fehler anzeigen. Das folgende Beispiel ist ein sehr häufiger Fehler in der EDI-Integration für Bestellungen:

Übersetzung fehlgeschlagen für 428967976 :
Übersetzungsprotokoll (1 Einträge):
----------------------------
FEHLER: /cXML/Request/OrderRequest; isAdhoc und SupplierPartId fehlen beide. Schließen Sie mindestens eine davon ein.
Übersetzungsbericht
------------------
Obligatorische Daten fehlen (100)
Gruppenname = ItemOut_cxml
Instanz = 00
Feld-ID = 3
Felddaten = null
Standardregelverwendungscode
Daten fehlen (142)
BlockCount = 57
Blockname = 2180_FOB
BlockSignatureIdTag = FOB
Feldname = 0335
Feldnummer = 5
Felddaten = ZZZ

Die FEHLER-Zeile erläutert in diesem Fall bereits die Ursache des Problems, ohne auf die EDI-Blockdetails zugreifen zu müssen. Spezifische Anweisungen für dieses Szenario finden Sie in der Bestellung, die mit dem Fehler "Übersetzung fehlgeschlagen (...) isAdhoc und SupplierPartId beide fehlen" fehlschlägt.


Siehe auch

Alle Implementierungs- und Konfigurationsleitfäden sowie zusätzliche Ressourcen zur EDI-Integration mit SAP Business Network finden Sie im Abschnitt Integration der Seite SAP Business Network für Handelspartner im SAP Help Portal.



Gilt für

Allgemeines Procurement > Ariba Administrator > Anwendungsintegration (zwischen Buying und Sourcing)

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