Support Note KB0404713
Email
PO is failing with error "PO-11: Cannot deliver order. (...) Translation failed". How do I use the EDI translation report for failed POs?
Symptom

Purchase order reached SAP Business Network, but failed to reach the supplier integrated system (via EDI) with the error message below:

PO-11: Cannot deliver order. Terminal error code for PO status: Translation failed for XXXX

How do I use the translation report for a failed purchase order to understand the cause of the error and resolve it?


Cause

The Translation failed error message will appear in several EDI integration error scenarios.

If it is appearing for a purchase order document, it means the order cXML document couldn't be translated to EDI, due to the cause outlined in the translation report. It can be an incorrect field or block data, or incorrect usage of these. Another common failure reason are POs with invalid characters, not supported by EDI.

The translation report is a very useful tool in identifying the cause of the integration error


Resolution

In order to view the translation report, follow the steps below:

  1. Sign-in to SAP Business Network.
  2. Locate the purchase order that failed with the Translation failed error.
  3. Click Order History.

The translation report is shown in the Comments column for the Failed status. It usually won't have line breaks, but will look like the example below:

Translation failed for XXXXXXXXX :
Translation Report
------------------
Incorrect Data Format(110)
BlockCount = 13
BlockName = ItemOut
BlockSignatureIdTag = LINE
FieldName = ItemID_SupplierPartID
FieldNumber = 3
FieldData = 152A77�
Incorrect Data Format(110)
BlockCount = 15
BlockName = 2010_PO1_ItemOut
BlockSignatureIdTag = PO1
FieldName = 0234_ItemID_SuppPartID_data
FieldNumber = 7
FieldData = 152A77�

The first line after the report title and delimiter (------------------) will inform what the issue is - for this specific case, incorrect data format. The field and block are shown right after it: the information block is ItemOut, and the field with incorrect or invalid data is the SupplierPartID.

In the example above it is clear there is an invalid character in the data (FieldData lines). This is not always shown so clearly in the translation report, though. If you are seeing an Incorrect data format error but cannot spot the incorrect character in the FieldData line, you can download the PO cXML from SAP Business Network and view it in an editor with support for non-ANSI characters, such as Microsoft Notepad or Notepad++.

A useful resource to use together with the translation report is the ANSI X12 Resource: 850 Purchase Order implementation guide, available under the Integration section of the SAP Business Network for Trading Partners page in the SAP Help Portal.

Note also that translation reports can shown multiple issues at once. The example above reports two occurrences of the same incorrect data format issue, for two different fields.

We can see also other errors in translation reports. See below one example of a Mandatory Data Missing error:

Translation failed for XXXXXXXXX :
Translation Report
------------------
Mandatory Data Missing(100)
BlockCount = 32
BlockName = Extrinsic
BlockSignatureIdTag = HDEXNA
FieldName = Extrinsic_name
FieldNumber = 1

In this example, an Extrinsic with no name was sent in the PO. Pulling the cXML for this PO we can see the snippet below, which caused this error:

<Extrinsic name=""/>

Finally, translation reports can also show errors directly, even before the report itself. The example below is a very common error in EDI integration for POs:

Translation failed for 428967976 :
Translation Log (1 entries):
----------------------------
ERROR: /cXML/Request/OrderRequest; isAdhoc and SupplierPartId both are missing.Include at least one of those.
Translation Report
------------------
Mandatory Data Missing(100)
GroupName = ItemOut_cxml
Instance = 00
FieldId = 3
FieldData = null
Standard Rule Use Code
Data Missing(142)
BlockCount = 57
BlockName = 2180_FOB
BlockSignatureIdTag = FOB
FieldName = 0335
FieldNumber = 5
FieldData = ZZZ

The ERROR line in this case already explains the cause for the issue, with no need to go over the EDI block details. Refer to PO failing with error "Translation failed (...) isAdhoc and SupplierPartId both are missing" for specific instructions on this scenario.


See Also

See the Integration section of the SAP Business Network for Trading Partners page in the SAP Help Portal for all implementation and configuration guides, and additional resources on EDI integration with SAP Business Network.



Applies To

Core Procurement > Core Administration > Application Integration (between Buying & Sourcing)

Terms of Use  |  Copyright  |  Security Disclosure  |  Privacy