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SAP Business Network/Ariba エンドポイントへの SM59 または SOAMANAGER 接続テスト時のエラー: "HTTP 500 Internal Sever Error"
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現象

支出管理および SAP Business Network 向け SAP Integration Suite 管理ゲートウェイサーバを対象とする HTTP 宛先 (トランザクション SM59 または SOAMANAGER) からの接続テストにより、以下のエラーが発生します。ステータス HTTP 応答 500 内部サーバエラー


原因

SM59SOAMANAGER などの SAP トランザクションの接続テスト機能は、基本的な空の HTTP 要求をターゲットサーバの URL に送信することによって機能します。これは、ネットワークレベルの接続のみを検証することを目的としています。

ただし、SAP Business Network および Ariba アプリケーションのエンドポイントは、特定のビジネスドキュメント (cXML ペイロードなど) を処理するように設計されています。SM59 によって送信された一般テスト依頼に応答するように設定されていません。

サーバはこの予期しない空の要求を受信すると、それを処理できず、HTTP 500 内部サーバエラーを返します。これは、アプリケーションレベルの障害を示すサーバの標準的な方法です。

重要なのは、HTTP 応答コード (500 を含む) を受信することで、下位レベルの接続が成功したことを確認することです。

  1. ホスト名の DNS 解決が機能しました。
  2. ファイアウォールまたはプロキシを介して TCP/IP 接続が確立されました。
  3. ターゲットサーバの Web サービスが有効であり、応答しています。

解決

ステータス HTTP 応答 500 エラーは、接続 (TCP/IP レイヤ) が機能していることを意味するため、無視することができます。


参照

支出管理および SAP Business Network 向け Integration Suite 管理ゲートウェイでサポートされている対象システム URL を確認するには、『支出管理および SAP Business Network 向け SAP Integration Suite 管理ゲートウェイの RFC 宛先の作成』ガイドのリンクを参照してください。



該当項目

SAP Integration Suite 管理ゲートウェイ > 管理ゲートウェイ - プラットフォーム > 管理ゲートウェイ - 購買側接続

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