Support Note KB0402013
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Why attachment sent in invoice or order confirmation from the SAP Business Network to SAP ERP system through Managed Gateway for Spend&Network isn't visible?
Symptom

When I send an invoice (InvoiceDetailRequest) or an order confirmation (OrderConfirmation) with an attachment from SAP Business Network to SAP Enterprise Resource Planning (ERP) via Managed Gateway for Spend&Network integration, I cannot find the attachment in the attachments list on the ERP.


Cause

Necessary configuration is not in place in SAP ERP.


Resolution

This issue generally happens due to a specific configuration missing on the Partner Profiles configuration for Managed Gateway for Spend&Network integration. The steps below should be followed to confirm this point:

  1. Open WE20 transaction.
  2. Click ARIBACIG/ARBCIG configuration on Partner Type LS.
  3. Double-click INVOIC for invoice, or ORDRSP for order confirmation, in the Inbound Parameters.
  4. Double-click INVL for invoice, or ORDR for order confirmation, in the Process Code under the Inbound Options tab.
  5. On the right-hand side of Identification > IDOC_INPUT_INVOIC_MRM for invoice, or IDOC_INPUT_ORDRSP for order confirmation, click on the ALE Table button.

After performing these steps you will reach to Display View "Function modules for inbound ALE-EDI": Details screen. There will be a specific label under the IDoc section called Success Event. This label cannot be blank, its value must be equal to INPUTSUCCESS.

It is highly important to know that for the attachments to work as expected, all the configurations mentioned in the SAP Integration Suite, Managed Gateway for Spend Management and SAP Business Network Configuration Guide How to enable attachments and comments for invoices and How to enable attachments for order confirmation should be in place. It won't work if, for example, the Event configured is MASSIMPUTFINISHED or if the ObjectType is IDPKINVOIC. The configuration must be done as mentioned in the guide.

If the configuration mentioned is already done and the issue still persists, please follow the below steps:

  1. Open SPRO transaction.
  2. Click Integration with other SAP Components > SAP Integration Suite, managed gateway for spend management and SAP Business Network > Global Settings > Support Attachments
  3. Click Maintain Parameter for Line Level Attachment from SAP Integration Suite, managed gateway for spend management and SAP Business Network

Add the parameters as mentioned in the SAP Integration Suite, Managed Gateway for Spend Management and SAP Business Network Configuration Guide How to enable attachments for order confirmation. Note that even if this guide section refers only to order confirmation, this specific part of the configuration is needed for both scenarios.

If after all the configuration is in place and the issue still exists, please refer to the steps mentioned in How to collect the trace to investigate issues with Invoice attachments sent from AN to ERP through Managed Gateway for Spend&Network in IDOC? and open a case reporting it with trace logs attached.


See Also

This scenario has a design limitation for line-level attachments. Any attachment sent at the line level will fail on the ERP side. A workaround would be to implement a customization in the ERP Customer Exits or enhancement spots.



Applies To

SAP Integration Suite Managed Gateway > Managed Gateway for Business Network
SAP Integration Suite Managed Gateway > Managed Gateway for Business Network > Managed Gateway for Business Network - Invoice
SAP Integration Suite Managed Gateway > Managed Gateway for Business Network > Managed Gateway for Business Network - OC

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