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Posta elettronica
Perché il numero dell'ordine d'acquisto non viene visualizzato nella pagina dei registri di controllo di Sourcing dopo l'assegnazione di una RDQ e la creazione di un ordine d'acquisto in SAP ERP?
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Sintomo

Il numero dell'ordine d'acquisto non viene visualizzato nella pagina dei registri di controllo di Ariba Sourcing dopo l'assegnazione della richiesta di quotazione (RDQ) e della creazione dell'ordine d'acquisto in SAP ERP.


Riproduzione del problema

L'intero scenario per la RDQ avviata in ERP è il seguente:

  1. Viene creata una richiesta di offerta nella transazione ERP ME41.
  2. A questo punto, il tipo di documento QuoteRequest viene inviato da ERP a SAP Integration Suite, gateway gestito per gestione della spesa e SAP Business Network. Dopo la trasformazione del documento, lo stesso viene inviato ad Ariba Sourcing.
  3. Dopo l'assegnazione in Ariba Sourcing, un tipo di documento QuoteMessageOrder (per ordine d'acquisto) o QuoteMessageContract (per contratto) viene reinviato da Ariba a SAP Integration Suite, gateway gestito per gestione della spesa e SAP Business Network e, dopo la trasformazione del documento, viene inviato a SAP ERP.
  4. Viene creato un ordine d'acquisto e l'interfaccia per la risposta al contratto invia una ContractStatusUpdateRequest a SAP Integration Suite, gateway gestito per gestione della spesa e SAP Business Network che viene instradata ad Ariba. Questo payload contiene l'aggiornamento dell'evento inviato a Sourcing.

Causa

Il numero dell'ordine d'acquisto non è visibile nei registri di controllo dell'evento di sourcing poiché il messaggio di conferma ContractStatusUpdateRequest non viene inviato correttamente da SAP ERP ad Ariba Sourcing dopo la creazione dell'ordine d'acquisto. Questo errore può essere dovuto a diversi motivi:


Soluzione

Se si riscontrano problemi con questo scenario, fare riferimento ai seguenti punti:

Se ContractStatusUpdateRequest non viene avviata dopo che ERP riceve QuoteMessageOrder:

  1. Accertarsi che l'interfaccia di risposta sia pubblicata. Passare alla transazione SPRO > IMG di riferimento SAP.
  2. Fare clic su Integrazione con altri componenti SAP > SAP Integration Suite, gateway gestito per gestione della spesa e SAP Business Network > Integrazione di SAP Ariba Strategic Sourcing Suite > Impostazioni generali > Configura interfaccia > Configura connessioni per l'invio di messaggi.
  3. Nella sezione Messaggi in uscita, assicurarsi che la Risposta contratto Ariba sia stata selezionata e pubblicata.
  4. Se l'interfaccia è stata pubblicata, assicurarsi di non avere errori nella transazione SRT_MONI che impediscono l'invio della risposta a SAP Integration Suite, gateway gestito per gestione della spesa e SAP Business Network (ad esempio 401 errori non autorizzati).
  5. Se non si verificano errori nella transazione SRT_MONI, controllare la presenza di errori anche nella transazione SLG1.

Se viene attivata la ContractStatusUpdateRequest (da ERP ad Ariba) dopo che QuoteMessageOrder/QuoteMessageContract è stato inviato al sistema ERP:

  1. SAP Integration Suite, gateway gestito per gestione della spesa e SAP Business Network > Transaction Tracker e cercare il messaggio ConctractStatusUpdateRequest.
  2. Scaricare il payload after-mapping e controllare se l'ID evento di sourcing è compilato nel payload.
  3. Se non è alimentato e si utilizza una versione SP precedente a SP5, controllare le seguenti note SAP:

Se la ContractStatusUpdateRequest viene attivata e l'evento non viene ancora visualizzato in Sourcing:

  1. Verificare con il team di sourcing se il parametro è abilitato: Messaggio di conferma da sistema esterno. Consultare Perché il messaggio di conferma di un messaggio di quotazione non aggiorna il progetto di sourcing?
  2. Controllare se la coda è registrata sul lato ERP. Vedere articolo: 1915747 - PurchasingContractSRMReplicationConfirmation_Out o PurchasingContractERPConfirmation_Out non avviato.

Vedi anche


Si applica a

SAP Integration Suite, gateway gestito > Gateway gestito per integrazione Sourcing

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